psychopy.org | Reference | Downloads | Github

PsychoPy Builder not creating HTML folder

I’m having an issue getting my project to run online (runs fine locally), and receiving the error message “unknown resource”.

Screen Shot 2020-10-17 at 12.05.50

I originally thought this must be a problem with my file path, and tried renaming the files/checking for spelling errors, actually changing the file types (new photos, png to jpeg and xlsx to csv), and starting a new project online, but these didn’t work. I realized while looking through the other forums that the issue was probably that Psychopy is not creating an HTML folder with resources in it when I “export HTML” in the builder and sync the project.

When I export html, it only creates an index.html (text). I have version 2020.2.4, and my main folder is on my computer desktop (macOS 10.15.6). Wondering if anyone else has had this problem, how to go about fixing it, or if there’s any way to manually create an HTML folder that I can upload to Pavlovia.

Screen Shot 2020-10-19 at 12.10.57

Any ideas are welcome- thanks!

Hi There,

PsychoPy now doesn’t create a html folder because essentially this was duplicating all the required resources, and using lots of space on pavlovia (because there were the resources outside and inside of your html folder!).

One thing to try though is adding the missing resource using the ‘online’ tab of your experiment settings - have you tried this?

Becca

Hey @Becca thanks for the response! I didn’t realize folders weren’t being created anymore. I tried adding the pictures to those “additional resources”, but am still getting the same error message unfortunately.

One thing is, looking at that error message, there is no extension on the name of the image. What happens if you add the extension?

Hi @Becca, no change when I add the extensions.

I’m having the same problem. Any solution to this?

I had a similar problem a few weeks ago which I managed to fix by just typing “html” in the output path of the “online” tab in experiment settings. Like this:
image

It creates a html folder and now my experiments work online for Pavlovia. For local debug to work, you have to delete html from the output path, leaving output path blank.

3 Likes

Thank you for the comment. I had same issue, adding html in output path solved the problem for me.

Dear all,

Newer versions of PsychoPy do not create a html folder anymore for a few important reasons. Please see this post for more details PsychoPy Builder not creating HTML folder

Thanks,

Becca

Hi Becca,
I checked the resources files and they were all uploaded properly to Pavlovia. My experiment only worked when I added “html” to the output path in experiment settings.

Does anyone know how to change the output path? I saved my experiment and files in a folder on my desktop and now that I am trying to get it online, I cant get it to change.

Hi There,

Best to make a completely empty folder, copy over only the .psyexp file and any supporting files (e.g. conditions.xlsx files or stimuli files) and then try a resync. The issue is if you try to sync a file on you desktop, it will try to send ALL of the files from your desktop to pavlovia. Following this there may be hidden .git files also on your desktop. Make a completely fresh folder and try the resync.

Becca

Becca,

Where am I creating this new folder, on my desktop again? Or somewhere else on the laptop?

Kind Regards,
Enna

Hi Enna,

It shouldn’t matter - so long as it is a fresh comletely empty folder that only contains the psychopy files needed to run the experiment.

Thanks,
Becca

Hi Becca,

I’m getting the same error as artibbs when I run on Pavlovia. I’m displaying images using their file paths. Works fine locally but not on Pavlovia. I tried adding all the files to “Additional Resources” and the problem kept occurring. I also added html to the out path but this didn’t fix the problem either.
Any other ideas?
Thanks.

Alex M.

Hi Alex,

Adding html will mean a second set of .js files are created (in a folder called html) which might confuse pavlovia (it will first try and use the files in html and then the files not in the html). In general we recommend not adding html to outpath now.

If you are still getting missing resource errors even after addint them to your online resource lists some other things you could try include clearing your browser cache and checking reference to all image files include the image extension (e.g. “.png”).

Hope this helps,
Becca

Hi there,

I am trying to set up an experiment that contains images to Pavlovia and it does not run, although it does perfectly run local in psychopy. I have tried all the above-mentioned tips and they did not seem to work for me. What else could I try?

Thank you,
Mavra

Hi There,

We are going to need more specific information to help here. Please can you start a new thread and detail what you have tried and if you have any specific error messages (if no error messages, what did you expect to happen that didn’t?)

That will help us in pin pointing the problem,

Thanks!
Becca

Hi Becca,

Thank you for your response, this is the error I get. Apparently, it is unable to detect the images. I tried the HTML trick but it did not work for me.

pavlovia_error

Hi,

When reporting an issue please open a new topic rather than posting it on an existing topic (e.g. “unknown resource” that will make it easier for future users to find your issue and how you solved it)

In this case it looks like you have a backslash in your path, try replacing with a forward slash.

Becca