psychopy.org | Reference | Downloads | Github

Installing an update on Win10 results in "I don't have the necessary permissions"


#1

Continuing the discussion from Installing a bug-fix update on Mac says I don't have the necessary permissions:

Continuing the discussion from useVersion error in 1.85.3:

If this template helps then use it. If not then just delete and start from scratch.

OS (e.g. Win10): Win10
PsychoPy version (e.g. 1.84.x): PsychoPy v3.0.0b9
**Standard Standalone? (y/n) y
**What are you trying to achieve?: Install update

**What did you try to make it work?: Download zip and try to install using unbuilt functionality

What specifically went wrong when you tried that?:
Include pasted full error message if possible. “could not move existing PsychoPy installation (permissions error)?”

First I got the error message above. After a restart of PsychoPy and new attempt, it displayed “Success”, but isn’t starting anymore.
After a restart of PsychoPy


#2

To fix the error in the title (permissions issue) you need to right-click the application icon to launch it, at the point when you’re intending to do the update. Being logged in as an admin isn’t enough - you need to launch as an admin.

The other issue that it doesn’t then launch may indicate that you’ve installed an incompatible patch version. In particular, newer patch releases don’t always work with older standalone installations because they might need additional dependencies.


#3

But I tried to install PsychoPy v3.0.0b10 onto PsychoPy v3.0.0b9. The difference between them shouldn’t be that big. I solved it now by upgrading using the Standalone-Installer. But now I get the problem stated here (Issue 5523).


#4

Right now PsychoPy is in a period of heavy development. I think between b9 and b10 we added the need for the lazy_import package so, yes, that might break things


#5

Thank you for the reply. Good to know.