psychopy.org | Reference | Downloads | Github

Installing a bug-fix update on Mac says I don't have the necessary permissions

#1

Hi,
(running PsychoPy on OS X 10.8.5)
I need to revert to 1.81.03 on my Mac (for whatever reason, that’s the last version that runs stably on any of my computers). Usually, I have no problem doing this reversion, (installing the standalone 1.81.0 and then upgrading to 1.81.03 via zip file) but I’m now getting the message when I try to install the zip file: “could not move existing PsychoPy installation (permissions error)?”. I tried running PsychoPy from Terminal with “sudo”, but this causes the message “Psychopy2 Error” to pop up and the following message in Terminal:

localhost:~ markscott$ sudo /Applications/PsychoPy2.app/Contents/MacOS/PsychoPy2
Traceback (most recent call last):
  File "/Applications/PsychoPy2.app/Contents/Resources/__boot__.py", line 429, in <module>
    _run()
  File "/Applications/PsychoPy2.app/Contents/Resources/__boot__.py", line 362, in _run
    exec(compile(source, path, 'exec'), globals(), globals())
  File "/Applications/PsychoPy2.app/Contents/Resources/psychopyApp.py", line 7, in <module>
    from psychopy.app._psychopyApp import *
ImportError: No module named psychopy.app._psychopyApp
2016-09-27 13:51:44.763 PsychoPy2[682:a07] PsychoPy2 Error

Doing this also corrupts the 1.81.0 installation - when I try to run it after doing this sudo attempt, it also pops up the “PsychoPy2 Error” message. I’ve gone through this pattern a few times, so it’s not a one off. I’m not very techy, so I could easily be doing something very stupid that’s causing this. For the time being I’ll reinstall 1.81.0 and stick with that; but I’d like to get to 1.81.03 which is my default version for my lab, so if anyone has suggestions, I’d love to hear them.

 Thanks,
 Mark
Installing an update on Win10 results in "I don't have the necessary permissions"
#2

If you use the Finder >Go>Go to Folder you can find the old psychopy folder in
/Applications/PsychoPy2.app/Contents/Resources/lib/python2.7/
(Or you can Show Contents of the app and drill down to that location)

Remove the psychopy folder from there and replace with the psychopy folder from inside your downloaded zip file.

I’m afraid I don’t know why you were having permissions problems. I’m not very surprised that recent versions are failing in some way under OS X 10.8. I’m afraid I don’t have any copies of OS X as old as that to test on.

1 Like
#3

Thanks! That worked like a charm. Yes, I definitely should update my OS, but I’ve got all kinds of software dependencies for experiments that I’m terrified many of them will break with an upgrade.
Thanks,
Mark