Platform unknown instead of PSYCHOJS

URL of experiment: Pavlovia

Description of the problem:

I have been trying to upload experiments to Pavlovia and all of them upload and appear as Platform unknown instead of PSYCHOJS, and when clicking on the link (which does not have the .html) a blank screen appears and nothing runs.

The synchronization does not yield any error messages and the html folder downloads correctly.

I never had this issue in the past. I currently have the latest version of Monterey 12.6 (MacOS) and also the latest version of PsychoPy (2022.2.4), but I also downgraded to Catalina to try and see if that was the problem, but the same issue arose.

Please, help.

If you can’t switch them to piloting or running then there’s probably a syntax error in your code. Try simplifying the experiment by disabling some of your components until it works

Thanks for responding @wakecarter

I am able to switch them to piloting and run, but after the switch it does not run in either mode. I have tried to upload to Pavlovia the simplest of routines and the same happens: Platform is marked as UNKNOWN. Then when my friend upload the same exact script (using the same system as my laptop and 2022.2.2 PsychoPy version) it worked as Platform PSYCHOJS. It just does not work from my computer (neither laptop not office computer) my Pavlovia account does not recognizes my PsychoPy scripts. Any other ideas? I have also delete and downloaded different versions of PsychoPy, nothing worked.


Hello,

do the experiments that are in running mode run? So can you rule out a syntax error?

Best wishes Jens

Some experiments do not run even when in running mode. So, I am able to change it to running mode (despited being tagged as UNKNOWN) but it still does not run. What is weird is that the same exact scrip uploaded from a colleague’s computer and Pavlovia account does run.

Hello Laura,

well, you need to provide more information, for instance access to your running and not-running experiments on Pavlovia.

And could you rule out a syntax error?

Best wishes Jens

Thanks, Jens. I rule out syntax error because I have uploaded the simplest of routines (only one routine with text component) as a text and it appears as platform UNKNOWN, also because the same script uploaded by someone else works wonders. I haven’t been able to upload an experiment in months now, I am a bit frustrated all experiments appear as UNKNOWN rather than platform PSYCHOJS.

I just tested this today October_25_test [PsychoPy] and it’s the same, I have provided access in case you are too kind and want to take a look. Thanks, again.

What do you have in Experiment Settings / Online in Builder? Your link is redirecting to https://run.pavlovia.org/laurapissani/october_25_test/index.html/ . Note index.html appearing as a folder name, which is not going to work.

I am attaching the properties. I had not notice that the link was doing that, the link on my end looks normal until I click it. I have no idea why is doing that. I have given you access in case you have the chance to take a look.

Screen Shot 2022-10-25 at 10.36.28 PM

Hello Laura,

as @wakecarter pointed out: The folder index.html is causing the problem. I simply deleted the folder locally, resynced and the “experiment” was running. I have no idea why PsychoPy created this folder.

Best wishes Jens

1 Like

I deleted the index.html on my local folder, ran it again and nothing. It still does not work. I also created a new one and that one does not have the /index.html attached to it and still does not work https://run.pavlovia.org/laurapissani/october_26. I wonder what else I can do. :frowning:

Hello Laura,

did you clear the browser cache before running the program?

Your new project does not contain any PsychoJS-files. So, it can not run online. When I complied the PsychoJS-files, it ran without problems. what happens when you manually compile the script to JS? Does it compile? Does it run a local browser?

Best wishes Jens

Yes, I deleted the index.html folder and put the files outside, then cleared the browser, and now the link does not end in index.html, but a 403 Forbidden error shows up (and still platform UNKOWN). It does run locally.

I am not sure what you mean by “compiled the PsychoJS-files”, is this to just copy and paste the html files to the same folder as the experiment file?

Thanks for all your help, I really want to solve this.

Hello Laura,

well, I simply deleted the html-folder without copying the files stored in it. But I guess that should matter. PsychoPY either compiles (exports) the PsychoJS-files when you sync the project. This is the default setting.

grafik

But you could also trigger this process by hitting the “Compile to JavaScript” button.

The html-file and the JavaScript-files should be in the same folder as the psyexp-file. See the attached example from another experiment:

Best wishes Jens

IT WORKED! Thanks so so much. I deleted the index.html folder and manually selected export html, and the synchronize one more time and now it is all good. Thanks again.