Exp won't run on Pavlovia after upgrading to 2023.2.3 - also some wierdnesses

URL of experiment: Pavlovia
OSX: 13.4
Standalone Psychopy V2023.2.3

Hi there.

I upgraded from 2022.2.5 to 2023.2.3 a few days ago - and am now experiencing problems with running experiments on Pavlovia (trying to pilot them).

At the moment, whenever I try to pilot an experiment I have uploaded, it remains stuck in the ‘Initialising’ screen.

I note too that the experiments I have uploaded since upgrading also don’t seem to be reporting their version number in my dashboard and the platform is ‘unkown’. Hmmmm…

By the way this is a big experiment - with 20Mb of image files - BUT… I have waited for a loooong time to see if it would eventually come good - and it hasn’t. Smaller experiments I have tried to upload suffer the same problem.

Could anyone have a look and/or suggest what I might be doing wrong here?

Thanks folks.



being stuck at the intialising screen and unkown platform usually means that the PsychoJS has errors. Does the program run properly in your local browser?

Best wishes Jens

Hi Jens.

Yes, works fine locally.

What kind of things should I be looking out for if this was the problem?



Hello Dan


Does that mean that it runs in browser locally by pressing

or that it runs as a Python script

What happens when you compile the JavaScript-code by pressing

Running it locally in a browser and/or compiling the JavaScript allows you to identify the error more easily than debugging the experiment online, at least with my skills.

Here is some help on how to debug the experiment online Debugging online - Thomas's demos. Unfortunately, the syntax error tutorial is no longer accessible (@thomas_pronk).

BTW, you provided a pilot-link for your experiment which expires within an hour.

Best wishes Jens

Ooooh. Good stuff! THanks Jens.

Will dig into this tomorrow.

(Runs locally by hitting the ‘play’ button - as python script).

Oh and - is this link more useful? Pavlovia

What thing should I link to in this instance?


Blur22.js doesn’t exist on the server. Can you see it locally? I suspect you are getting an error when you compile or sync.

1 Like


run it locally as a JavaScript in a local browser. as @wakecarter suspects there will be an error when you compile or sync.

Best wishes Jens

Ah. Ok. This is getting interesting.

I just uploaded a little test experiment. Pavlovia

Seemed to upload ok with no errrors reported in the little progress window that pops up during Sync.

But it is in the same state as Blur22. In my Pavlovia dashboard it is also platform: ‘Unknown’ and version: ‘0’ version.

Note this was a new little experiment I was just testing things out with so shares no code-base with Blur22 and is quite simple.

Also @wakecarter - following your suggestion that there is no .js for Blur22 on the server I tried to run it again and - it looking at the console output for the experiment when it tries to run (stuck on Initialising) - I see this error:

Screenshot 2024-01-11 at 8.07.26 am

Ok. Sure. But when I go to the Github repository (is the right term? I’m not super familiar with Github), I see this:

Note the different name of the .js project. In the ‘Experiment name’ field in the settings it is set to ‘Blur22’ - which I specified as the project name the first time I uploaded this. Perhaps this field is not being updated to modify the 'js filename? Or somehow all these different versions of the experiment name are not being kept in Sync?

Ahah! This looks like it was the problem. A mismatch of the experiment name as set in ‘Experiment settings’ (or perhaps defined when I uploaded for the first time and was asked to set an experiment name’?) and the actual .js filename.

I just copied the entire local experiment folder, renamed the .psyexp file to ‘Blur_expera_23.psyexp’, blew away the two hidden ‘git’ files, ran it up, changed the name manually in the experiment settings page to be the same: ‘Blur_expera_23.psyexp’ and then Uploaded/Synced and… presto it works!!! Also the correct version number and platform are now displayed in my dashboard. YAY!

So it would appear that when uploading, either specifcying the project name OR the field in experiment settings does not modify the .js file - meaning the when you try to run it - it looks for the .js filename - and if different to the two places mentioned above - it can’t find the file.

So - great - we’ve figured this out and I can continue working now. YAY!!! THanks so much folks!

But also - I have to say I have just had ENDLESS problems with this and similar issues to do with the name of the experiment seemingly being maintained in several different locations and these getting out of sync. In particular the fact that those two hidden files seem to determine where the project tries to upload to etc… This all feels really confusing and has cost me a LOT of time and frustration historically.


I’m back in action over here. Thanks for your help both @JensBoelte and @wakecarter.



Sorry. I should be better at spotting that mismatch name bug. I’m pretty sure it has already been fixed for the next release and only crept in in 2023.2 (as a way to address a different issue).

Ah fantastic! Great to hear!

Thanks so much. :slight_smile:



You are not alone. I ran into the same problem with one of my students’ experiments. They named the experiment in Edit Experiment Settings - Experiment Name.

I had never used this parameter before. The Python code ran fine, but the JavaScript code didn’t. It took me some time to discover the problem.

Best wishes Jens