Platform unknown instead of PSYCHOJS when syncing experiment to pavlovia / forbidden error 403

Hi all,
I am having some trouble with getting my experiment to successfully transfer from psychopy to pavlovia. It runs fine locally on psychopy but when I sync the experiment to pavlovia the platform is listed as “UNKOWN” when it should be “PSYCHOJS”. I have looked at similar posts on the forums and tried all options I could see (e.g., adding /html to the study link, deleting and re-downloading psychopy, deleting the study from the experiment dashboard on pavlovia and trying again). I successfully ran this experiment on pavlovia back in 2021 and I am using the exact same experiment file, just with photos in the experiment folder changed.

Any suggestions or help would be greatly appreciated!

Change the name of the experiment in Experiment Settings to match the file name.

I have solved this! Turns out the version of psychopy in my settings was set at the wrong one (2023 instead of 2023.2.3)

I tend to leave the version field blank whenever possible.