psychopy.org | Reference | Downloads | Github

Pavlovia experiment stuck on first screen

URL of experiment: https://run.pavlovia.org/abhilashak9/tot_online/html/

Description of the problem: I actually had a properly working experiment. I just added a few more objects to my routines to complete the experiment, and now for some reason, I am not able to advance to the task at all, i.e., I have two introduction screens to which the participant should be pressing the ‘R’ key and the trials should start, but the online version is just stuck on the second screen. I tried inspecting the routine and even removing it, but seems like that doesn’t change the issue. I also looked at the console and I’m getting a bunch of errors I don’t understand. Any help is appreciated!

Attached is the psyexp file, which by the way runs just fine. I’m not sure what I changed that the experiment has suddenly stopped working on pavlovia.

TOTfinal.psyexp (165.5 KB) TOTstimuli.xlsx (9.6 KB) TOT_prac.xlsx (9.0 KB)

Thanks!

Your link actually works on my machine. Is it possible you were trying to launch in Internet Explorer? I’m afraid support for that is curently broken. Could you try opening in another browser instead?

@jon, thanks for replying. I tried it in safari and chrome and am facing the same issue. It does open up and get through the first screen of instructions to the second screen but doesn’t work after that. Are you able to actually do the task?

On mac firefox and mac chrome I’m being asked questions and typing in answers (quite cool by the way!)

@jon thanks for trying again! I just tried it and it seems like I can only run the task incognito on mac chrome and mac safari. Does this have something to do with my cache? And if so, how do I clear it?

Thanks again for trying the experiment!

I wasn’t incognito when I ran. Yes, maybe the experiment wasn’t working ealier but is now, any your copy hasn’t updated. I think you need to do Shift-Cmd-R on a Mac to refresh the page including all JS code

It works, I think the copy just wasn’t getting updated. Thank you for troubleshooting!