Pavlovia crashes when I try to pilot experiment

URL of experiment: (this is where the code is, I’m not quite sure which URL I’m supposed to post)

Description of the problem: This past Friday (10/2), Pavlovia all of a sudden started crashing every time I try to pilot my experiment. I click “pilot”, it opens the experiment, the dialogue box to enter the participant ID pops up, I click “okay”, then the experiment enters full-screen mode, but the dialogue box doesn’t go away. The “okay” button turns blue like it was clicked, but it just freezes. When I open the developer tools console, there is literally nothing there–no script, no error, nothing. Then when I close out of the pilot tab, all of the other Pavlovia tabs (I always have my dashboard, experiment, and code Pavlovia pages open) won’t reload. I have to close out of everything Pavlovia and reopen it again. While they’re still open, my computer sounds like a plane taking off. And this happened out of nowhere–everything was working fine and then it just wasn’t. It’s weird that no one else seems to be having this problem…

If this post looks familiar, it’s because it’s a repost from two days ago that I never got a response to. I typically end up driving myself crazy trying to figure things out on my own when I don’t get responses, but I literally don’t even know where to begin here and really need help. There are no errors or anything, so I’m not sure if it’s an issue with my code, the website, some mixture of both, or something else entirely.

Things I’ve checked/tried:

  • My internet is fine
  • All other websites are working fine
  • My code works in builder
  • I’ve re-synced the builder experiment to a new Pavlovia experiment
  • All files are synced to Pavlovia correctly
  • I’ve restarted my computer multiple times
  • I’ve tried running it without any other tabs/programs (closing everything really hurt :frowning:)
  • I’ve tried running it in Microsoft Edge (I usually use Chrome)
  • I posted here looking for help (and helped others for good karma)

Any help would be much appreciated :heart:

@jon can you help maybe? :pleading_face:

I’m not @jon, but I maybe I could help out :slight_smile:. Could you make me a member of your gitlab repo so I can take a look? My username is tpronk

Hi thank you for responding! It actually miraculously started working again last night, but I have no idea how/why and I don’t trust it so I added you in case it happens again…