psychopy.org | Reference | Downloads | Github

Unable to run 2 experiments and a demo (properly/at all) on Pavlovia

URLs of experiments:
https://run.pavlovia.org/cc99/imagerystudy/html/
https://run.pavlovia.org/cc99/mentalrotationdemo/html/
https://run.pavlovia.org/cc99/vviqblocked/html/

Description of the problem:
The above 3 experiments all have trouble running online. All work fine locally.

The first one is a questionnaire, but hardcoded through text components, and worked fine until 1.5 week ago. Now, it quits unexpectedly in the middle of running (but at variable times) and the page freezes completely. This seems to happen only in Safari, as I’ve tried Chrome too and there it works. It gives no error message in Safari.

The second one is the PsychoPy3 mental rotation demo. This also works fine locally, but on Pavlovia only opens a gray screen, which also freezes. I would like to use the demo’s format to tweak and further develop my own mental rotation experiment, but I want to get to know how to make it work online first as we’ll be testing participants online only. This also shows no error messages in Safari, but in Chrome we got:
9a5ca97fc819eddb4159698ae0ac4e4c7dbb82a5_2_434x375

The third one is the same questionnaire as experiment 1, but I made it anew using the new form components in hopes of having less issues screen-wise (i.e. using different screen sizes with online testing, which was a problem before even with only using height units) or otherwise. Unfortunately, when running this one on Pavlovia, all that shows up is the end page - somehow it completely skips past the form routines. (Does it being a novel feature have anything to do with it not going online?)

Any help would be much appreciated as we’re trying to build some experiments this month all of which we want to start running online from Pavlovia starting September. Sadly, somehow everything I try seems to end up being problematic in a different way. :cry:
For all experiments, when I try to sync it to gitlab again after some trial-and-error edits, it very often hangs on “Synchronizing…” in builder, and the only thing to do is to delete the whole project from gitlab and sync from scratch, which doesn’t feel like an elegant solution.

As the https://run.pavlovia.org/cc99/imagerystudy/html/ experiment worked fine at first, I thought this was a change-at-server issue, but now that nothing works I’m not so sure anymore.

Thanks so much in advance for any tips and help!

Hi @carlijn, the imagery study seems ok to me. It works fine all the way till the end of the task. The only issue is that you cannot progress through the trials until the keyboard becomes active.

The mental rotation task has an issue where you are using a raisedCos mask in your images. This does not seem to be implemented yet, so I will raise an issue. To fix, you could remove the mask to get your task functional.

Regarding the sync error, are you editing your experiments locally, or on Pavlovia?

Hi David, thanks so much for your quick answer.

Good to hear the imagery experiment works for you. Unfortunately, I still get the same thing where it shuts down out of nowhere, I’ve filmed what happens so you can maybe see what’s going on here. Can’t share video files on here so I made it public on a google drive; https://drive.google.com/file/d/1ttEtwk4qIpd6y-Ag80MpZtYhVjuJwyyR/view?usp=sharing
(And indeed, I put in a delay of 10 seconds before one can get to the next screen to ensure participants are not just clicking through the questionnaire.)

Have you heard of any other experiments shutting down mid-task before? The strange thing is, it used to work perfectly, but somehow last week it just quit doing that.

I’ve tried this but I still only get a grey screen when I run it on Pavlovia.

I’m editing my experiments locally - I did not know that there was an option to do this in Pavlovia. Would editing it in Pavlovia help, and if yes, where do I do that? :slight_smile:

Any ideas on this one?

Ok, I see. Yes, it just crashes in your vid, can you let us know your OS version and browser you are using? Perhaps @apitiot can help understand why the task would crash.

Your mental rotation task works after removing ‘raisedCos’ on Windows Chrome now. If you are still getting the old error, try refreshing your browser cache using ⌘ + R. However, you will now get an error that limage is not defined, I think because that is not a variable used in a your conditions file.

That’s good, keep editing them locally. Sometimes, if you edit both local and online tasks simultaneously, you will have a conflict that Git cannot solve. So, best not to edit tasks online.

Regarding the Form component, it is in development, and so not available online (yet). I think your current task is fine without a Form, we just need to figure out why it is crashing.

@carlijn, perhaps you could show us the crash again, but this time with developers tools open on the browser.

With your task about to start in the browser, right click and select “page source” and navigate to the console tab in the developers tools. If you do not have this option, you need to go to Safari > Preferences > Advanced, and select the Show the develop menu.

When this is working, run the task and show the output in the console simultaneously.

Here it is now, this time crashing a few more screens in at 0:48. https://drive.google.com/file/d/1oWmruCxKTiHx2dAUa_u0XlHT4z68lj49/view?usp=sharing

As you can see, the console falls away and turns black during the experiment, and afterwards, as the screen is completely frozen, I’m not able to click on any of the error messages to get more information, or even go to any other of the development tabs.

It’s been tried on 3 Macs so far, one running on Mojave 10.14.5 with Safari 12.1.1, and the other two both on Mojave 10.14.2 with Safari 12.0.2. Running it with Chrome on all machines seems to go fine.

Okay, sounds good. I was trying out the form component because I was hoping it’d lead to less crashes or screen issues with different screen sizes due to hardcoding text components in place, and I think overall that once it’s supported it will be an amazing tool!

And thanks, I’ll try figuring this out and getting it to work!

Great, thanks for showing us the movie. Hopefully @apitiot can shed some light on what is happening. I have been able to run this task without crashes in Safari 12.02 on a Mac running Mojave.

Here is the link again, for Alain:

https://run.pavlovia.org/cc99/imagerystudy/html

1 Like

any thoughts @apitiot?