Errors with 2020.2.2 release


After installing the latest release, I run into errors (macOS Catalina Version 10.15.5). Opening PsychoPy form app icon results only to an error window (with options to open console or terminate). I still can open PsychoPy from terminal but clicking on any components in the builder GUI results in the following:

Traceback (most recent call last):
File “/usr/local/lib/python3.8/site-packages/psychopy/app/builder/”, line 2239, in onClick
dlg = _Dlg(frame=self.frame,
File “/usr/local/lib/python3.8/site-packages/psychopy/app/builder/dialogs/”, line 1786, in init
_BaseParamsDlg.init(self, frame, title, params, order,
File “/usr/local/lib/python3.8/site-packages/psychopy/app/builder/dialogs/”, line 523, in init
ctrls = self.addCategoryOfParams(theseParams, parent=page)
File “/usr/local/lib/python3.8/site-packages/psychopy/app/builder/dialogs/”, line 636, in addCategoryOfParams
self.addParam(fieldName, parent, sizer, currRow,
File “/usr/local/lib/python3.8/site-packages/psychopy/app/builder/dialogs/”, line 789, in addParam
wx._core.wxAssertionError: C++ assertion “”m_refData != __null”” failed at /Users/robind/projects/bb2/dist-osx-py38/build/ext/wxWidgets/src/osx/carbon/ in OSXGetNSFont(): invalid font

Terminal also gives a “Fontconfig warning: ignoring UTF-8: not a valid region tag” when opening the program. Maybe related?

Any ideas how to solve this?



The most recent MacOS version of PsychoPy seems to have a lot of issues unfortunately, a bunch of us have encountered the same error as you described. Personally I just downgraded to 2020.1.3 (which confusingly enough seems to have the version no. 2020.1.2 when I look in the ‘about’ info) in the meantime.

Thanks for a quick reply. I’ll try the 2020.1.3 release.

Sorry, although thanks for the useful error message. I’m sure we can get that fixed - looks like the machine I test on had a different set of fonts so didn’t reveal the error. We’ve changed the fonts calls a little as part of the theme work and clearly that’s caused a problem on some macs

1 Like

Dear Jon
Congrats for this new release and for the great job behind psychopy! =]
I installed the 2020.2.2 release in admin mode (dell latitude laptop running W7 with a graphic card intel HD 520, with drivers uptodate), and started psychopy from the command line. Unfortunately i ran into the error below. Would you have any suggestion? Thanks a lot
All the best

“C:\Program Files\PsychoPy3\python.exe” -m

pygame 1.9.6
Hello from the pygame community.
Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\site-packages\pyglet_ init”, line 378, in getattr return getattr(self._module, name)
AttributeError: ‘NoneType’ object has no attribute ‘get_platform’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\”, line 193, in run_module_as_main “ main ”, mod_spec)
File “C:\Program Files\PsychoPy3\lib\”, line 85, in run_code exec(code, run_globals)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\”, line 104, in main()
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\”, line 100, in main start_app()
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\”, line 22, in start_app from psychopyApp import PsychoPyApp
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\”, line 23, in from . import themes
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\themes_ init
.py”, line 1, in from . themes import ThemeMixin, IconCache
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\”, line 30, in allCompons = components.getAllComponents() # ensures that the icons get checked
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\experiment\components_ init
.py”, line 59, in getAllComponents components = getComponents(fetchIcons=fetchIcons) # get the built-ins
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\experiment\components_ init
.py”, line 154, in getComponents module = import_module(explicit_rel_path, package=pkg)
File “C:\Program Files\PsychoPy3\lib\importlib_ init
.py”, line 126, in import_module return bootstrap. gcd_import(name[level:], package, level)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\experiment\components\form_ init
.py”, line 12, in from psychopy.visual import form
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\visual_ init
.py”, line 28, in from .button import ButtonStim
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\visual\”, line 12, in from psychopy import event
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\”, line 59, in default_display = pyglet.window.get_platform().get_default_display()
File “C:\Program Files\PsychoPy3\lib\site-packages\pyglet_ init .py”, line 384, in getattr import (import_name)
File “C:\Program Files\PsychoPy3\lib\site-packages\pyglet\window
init .py”, line 1896, in gl. create_shadow_window()
File "C:\Program Files\PsychoPy3\lib\site-packages\pyglet\gl
.py", line 208, in create_shadow_window shadow_window = Window(width=1, height=1, visible=False)
File “C:\Program Files\PsychoPy3\lib\site-packages\pyglet\window\win32_ init
.py”, line 134, in init super(Win32Window, self). init (*args, **kwargs)
File “C:\Program Files\PsychoPy3\lib\site-packages\pyglet\window_ init
.py”, line 571, in init self. create()
File “C:\Program Files\PsychoPy3\lib\site-packages\pyglet\window\win32_ init
.py”, line 271, in create self.switch_to()
File “C:\Program Files\PsychoPy3\lib\site-packages\pyglet\window\win32_ init
.py”, line 317, in switch_to self.context.set_current()
File “C:\Program Files\PsychoPy3\lib\site-packages\pyglet\gl\”, line 216, in set_current wgl.wglMakeCurrent(self.canvas.hdc, self._context)
OSError: exception: access violation reading 0x0000000000000028

Hello :slight_smile: Here are a few of the errors I encountered yesterday:

Also: can you please, please find a better way to introduce new lines in the text component?! The new method is a nightmare to edit (it has automatically removed spacing between words for existing text components to introduce a new line?!)

Just to quickly comment that the new 2020.2.3 release seems to work at least on my machine! How splendid! Thank you!

1 Like