Hi I am trying to download the older version of psychopy 2020.2.3

OS (e.g. Win10): macOS Monterey 12.6.2
PsychoPy version (e.g. 1.84.x): 2020.2.3
Standard Standalone? (y/n) If not then what?:
**What are you trying to achieve? : I am trying to download and use the 2020.2.3 version on my MacBook air. Our experiment was created using the 2020.2.3 version so we wanted everyone to download this.

What specifically went wrong when you tried that?:

Traceback (most recent call last):
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/pyglet/init.py”, line 378, in getattr
AttributeError: ‘NoneType’ object has no attribute ‘_create_shadow_window’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/Applications/PsychoPy.app/Contents/Resources/boot.py”, line 498, in
File “/Applications/PsychoPy.app/Contents/Resources/boot.py”, line 476, in _run
File “/Applications/PsychoPy.app/Contents/Resources/psychopyApp.py”, line 104, in
File “/Applications/PsychoPy.app/Contents/Resources/psychopyApp.py”, line 100, in main
File “/Applications/PsychoPy.app/Contents/Resources/psychopyApp.py”, line 28, in start_app
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/app/_psychopyApp.py”, line 226, in init
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/app/_psychopyApp.py”, line 262, in onInit
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/app/builder/init.py”, line 7, in
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/app/builder/builder.py”, line 46, in
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/app/builder/dialogs/init.py”, line 27, in
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/app/builder/validators.py”, line 27, in
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/pyglet/window/init.py”, line 1896, in
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/pyglet/init.py”, line 384, in getattr
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/pyglet/gl/init.py”, line 100, in
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/pyglet/gl/lib.py”, line 141, in
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/pyglet/gl/lib_agl.py”, line 49, in
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/pyglet/lib.py”, line 118, in load_library
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/pyglet/lib.py”, line 286, in load_framework
ImportError: Can’t find framework /System/Library/Frameworks/OpenGL.framework.


you know that you can set the PsychoPy-version in the Experiment properties? And do you know that your experiment doesn’t run in the current version?

Best wishes Jens

If you want to use an old version I would recommend that you try 2020.2.10. It’s very stable and excellent if you don’t need any of the more recent features.

2020.2.3 is in my list of versions to avoid

More on the bug you’ve encountered

yes we tried running the experiment in the latest version it does not run! oh I did not know u can set the psychopy version in the experiment properties! Just to check, this is in the new version of the psychopy?


at least the version @wakecarter suggests, allows you to set the PsychoPy-version.

Best wishes Jens