PsychoPy 2020.2.3 font issue on macOS


I’m having issues with PsychoPy 2020.2.3 on a MacBook Pro (macOS 10.15.6; late 2013). After launching PsychoPy 2020.2.3, I get the following error when clicking on any of the components:

Traceback (most recent call last):
File “/Applications/PsychoPy3 2020.2.3/”, line 2244, in onClick
File “/Applications/PsychoPy3 2020.2.3/”, line 1789, in init
File “/Applications/PsychoPy3 2020.2.3/”, line 523, in init
File “/Applications/PsychoPy3 2020.2.3/”, line 637, in addCategoryOfParams
File “/Applications/PsychoPy3 2020.2.3/”, line 789, in addParam
wx._core.wxAssertionError: C++ assertion “”m_refData != __null”” failed at /Users/robind/projects/bb2/dist-osx-py36/build/ext/wxWidgets/src/osx/carbon/ in OSXGetNSFont(): invalid font

It seems that there is an issue with linking to “/Users/robing/projects…”? which does not exist on my mac.

I’m teaching a course lab using PsychoPy for the first time, and one of my students just reported the same problem. We’re using PsychoPy 2020.1.3 (not 2020.2.3, which Walter mentions in the original post). But the error code is almost exactly the same. Any help would be greatly appreciated!

Redownloading PsychoPy fixed the issue. It seems that a new Mac version has been made available because the name has changed from PsychoPy3 to PsychoPy.

Short story: Correct.

Explanation: Because of the pains of recent Catalina/Mojave gatekeepers blocking the app, we uploaded a couple of versions of 2020.2.3 release candidates (they were labelled Test Release and had the suffix rc1, rc2 etc in the dmg file) for the mac. We fixed the font bug while these were being generated so the final 2020.2.3 dmg file contained the fixed version.

Name change: For the final release we started registering the app with Apple and signing it. I wanted Apple to call this PsychoPy not PsychoPy3 as the name of the app so the app changed name then.

I’m running into the same problem with 2020.1.3 (app is also called PsychoPy3 when I download it). Any chance of getting a fix for that version as well?

We can’t fix versions that are already released. You should download the new version instead

Makes sense, thanks for the reply!

I am also teaching a course using Psychopy. However, a few students who use Mac have problems running a simple task in Builder, no matter the task contains just a text page or an image. Very often there is no error information. After click “run”, there will be a gray screen showing for a second or so, then the task will quit, and everything seems normal again.
We tried 2020.2.3 and 2020.2.4 and had the same results. A couple of students also tried the Stroop demo task, and have the same problem.
If you have had a similar situation and found a solution, please let me know and I will really appreciate your help.