"Unknown resource" issue for .png image and "Uncaught syntaxError: Unexpected end of input"

I am trying to run an online experiment which has two part: Test and training.
For a better understanding of error, I have coded the experiment in fragments (Test experiment and training experiment) and tried to push them online.

Training experiment
online experiment ceated successfully. This is starting and showing instructions, but when coming to display image part, it is showing the following error.

"Unfortunately we encountered the following error:

  • when setting the image of ImageStim: image
  • when getting the value of resource: grp1Letter\adlam_10.png
  • unknown resource

Try to run the experiment again. If the error persists, contact the experiment designer."

PS: I have copied the images locally in html\resources\grp1Letter locally, and re-synced. Still the error persists

Test experiment
This error is coming while creating Online experiment.

`1. “Uncaught syntaxError: Unexpected end of input”: here the line of error is 1311, while the code length is only 1310.
2. “failed to load resource: the server responded with a status of 404()”

I have tried a lot to debug and fixed these issues.

Your input will be really a great help to me!
Thanks in advance.

It looks like your image path has a backslash instead of a forward slash. Try changing to forward and see if that fixes.

Also I’d check that the resources folder did in fact sync successfully— I’ve been having an issue lately where changes appear to sync successfully, but looking at git history, they actually didn’t. If that’s the issue, clearing cache and re-syncing might fix.

Thank you. The forward slash totally worked for the “Unknown resource” problem.

The “Uncaught syntaxError” issue is also solved.

Thank you very much for your help.