Unknown Resource Error part II

URL of experiment: Sign in · GitLab

Description of the problem:

Unfortunately we encountered the following error:
when setting the image of ImageStim: welcomeSlide
when getting the value of resource: resources/welcome.PNG
unknown resource

I had an almost identical issue recently: Showing images based on Slider response - working locally but not on Pavlovia - #6 by JensBoelte

I solved it by adding my image files to the ‘online’ tab in the settings. Only difference is those images were conditional based on slider response, while this time its just a simple image component.

It was working perfectly fine online. Then, I had made some small changes locally (just some text component changes, nothing to do with any images) and they weren’t updating on Pavlovia. So I:

  • Deleted the .git folder and html file, cleared my cache/browser history, regenerated the .js file, and synced again.

  • It still would not sync, so I deleted the experiment in Pavlovia, copied the experiment and the resources into a fresh local folder, deleted the .git and html from the old folder, cleared cache, and uploaded it as a new experiment. Now, the experiment will start online but I get the above error after the participant # screen.

  • I tried deleting all the resources in the settings>online screen and re-uploading in case it was a path issue. Made no difference.

I know this is a really common issue and I have tried all the suggestions I could find. The resources are listed in the .js file like this:

Something odd that I didn’t notice when it was running correctly - I have my own folder named “resources” and whenever I sync, it creates a new resource folder within my resource folder. I thought maybe this resourception is causing a path issue, so I deleted it, but it just regenerates when I sync (looks the same in gitlab).


The only thing I haven’t tried that has solved issues for me in the past is creating a whole new Psychopy experiment and individually copy/pasting all the components into it. This is SUCH a pain in the butt so I’m hoping someone can give me another suggestion. TIA (:

Within 5 minutes of posting this I figured it out myself - turns out the .js file was not updating automatically and actually didn’t have the list of resources in it. I had to open my local experiment, generate the .js file, save it manually, and sync. Works fine now (: