psychopy.org | Reference | Downloads | Github

Sync error/404/403 errors

URL of experiment: https://pavlovia.org/lcdlab/picture-game-1

Description of the problem: I have two versions of this task, one seems to sync and work fine, I can pilot it. This version gives me trouble syncing, sometimes will say sync failed but will still show up as updated in github.
I read on here that where the folders are located could cause these problems, but the folder locations look the same for both versions and the other one can be piloted. I get a 404 or 403 error when I try to pilot this version, and I tried syncing it (after exporting html) multiple times. Each time it tells me that this project doesn’t belong and I have to (re)create a project.

Any ideas why I cannot pilot or sync this?

@BaharSener, I am not sure what is happening, the experiment uploads ok for me. If you have not started collecting the data, you could delete the local and remote repo for the task that is not working, and start again. If you want to do this, then for the local repo, delete the hidden .git folder in your project directory, and restart PsychoPy. For the online repo, go to gitlab and delete the corresponding online repo e.g., https://gitlab.pavlovia.org/lcdlab/picture-game-1. Also, make sure that your project folder does not reside in another project folder.

1 Like

@dvbridges thank you! I deleted and then made a new project, and psychopy stopped responding. When I checked on pavlovia I saw that the project was created but the repository is empty. I tried this couple times and it never synced the repository. I just want to make sure my project folder isn’t in another project folder, by that which folder do you mean? I have the psyexp and .js documents on my local folder and in it there are ‘psycache’ ‘html’ and ‘resources’ folders.

I think I also had that, but left PsychoPy to finish what it was doing, and the project eventually uploaded. Did PsychoPy close when you had the not responding issue?

I just had another go at created a new project with your files, and psychopy did hang whilst the files were being uploaded, but eventually finished after maybe a minute. So, I would try again, but when PsychoPy seems to hang, just leave it to finish the upload to Pavlovia.

1 Like

Thank you very much!

@dvbridges thank you for all your help and trying to upload, I appreciate it a lot. I tried multiple times yesterday (from different computers as well) and let it hang, but each time the repository was empty. I am syncing directly from the PsychoPy “pavlovia.org” tab. Should I be using something else such as GitHub Desktop app?

No problem, but unfortunately I do not why you are having the issues uploading. Perhaps @apitiot or @jon might be able to figure out what is happening on Pavlovia when you are trying to upload.

Here is an example of my upload, which worked after hanging for 30 seconds or so.
`https://gitlab.pavlovia.org/dvbridges/testing_bahar