psychopy.org | Reference | Downloads | Github

PsychoPy Not syncing correctly to Pavlovia

Hello,

I’ve recreated the Stroop experiment in Psychopy. Saved my file. Exported it as an HTML. I’ve logged into my Pavlovia account from PsychoPy. I clicked on sync and followed the steps. Yesterday I was getting a 403 forbidden error which I tried solving by:

  • deleting resyncing the Experiment
  • going from pilot back to inactive and then back to pilot
  • redoing the experiment from scratch
  • changing the directory of the file as mentioned in the error box.

Nothing really worked. I went to sleep and woke up today to work on it. Today, PsychoPy gets stuck on the loading cursor and never really finishes syncing.
I tried the methods above, again. As well as tried uninstalling PsychoPy and reinstalling it.
Although the experiment appears on Pavlovia, it never finished syncing on my local software. I tried piloting it in this situation, and still same error.

What should I do? Thanks for your help kind people.

Where are you saving your local files? (cloud storage can cause problems)

What version of PsychoPy are you using?

Are you clicking on the sync icon within Builder?

Are you getting any errors in any local windows (it might be hanging because there’s another window waiting for input in the background)?

Hey Wakecarter,

Thank you for your response. For your questions:

  • I am saving my files locally.
  • I used two different versions of PsychoPy to test out the bug. One is the latest and the other one being the 2021.1.4 version. (Release Release 2021.1.4 · psychopy/psychopy · GitHub))
  • I indeed click on the sync icon within Builder.
  • I am getting these errors in the local window: