psychopy.org | Reference | Downloads | Github

Experiment doesn't sync with pavlovia

URL of experiment: https://run.pavlovia.org/mykolasss/nzzzznn/?__pilotToken=c51ce410c124a10e0db5e4b97fc2af39&__oauthToken=a8d4af564284394dedf2a3955a681a848e926235b36132908511a2b11f6595a5

Hello, I’m trying to sync my experiment to a project in pavlovia from the coder view. It is syncing pretty fast, creates a .git repository with all the experiment files and the runner shows that syncing is successfull, but when I try to pilot the experiment it shows “403 Forbidden”. I tried deleting .git folder, creating a new project, but nothing works. I managed to sync the experiment to a different project before and it worked (URL: garsinis_screenscale [PsychoPy]), but I needed to add a screen scale routine and a few survey components, though I don’t think this is the problem. What could be the issue?

Could you share you gitlab repo with me? (make me a maintainer, my username is tpronk). Then I’ll take a peek

Thank you for your response, all done!

Thnx! I see your project name is vvgbhnjmk and not nzzzznn. Maybe try this one? Pavlovia

I deleted the nzzzznn project about an hour ago, and tried to sync to the first one. I tried piloting this one too: Pavlovia , but it still shows “403 Forbidden”, so I guess it didn’t sync properly

In the dashoard it shows that the project type is unknown, it just has a git repository and that’s it

I just found that when I open the github repository it shows that I need to add SSH key to my profile. Could it be the reason why I can’t sync the experiment? I haven’t added the key before, but managed to sync successfully

Are you syncing via the PsychoPy Builder?

Through coder, though I tried to sync via builder and the same happens. I tried downgrading psychopy to 2020.2.4 (which the experiment was originally made in), tried changing experiment versions in experiment settings, but still the same issue remains

Sorry for all the besoignes! I notice I can’t get into your gitlab project. I’ll go relay this problem to a colleague, who will likely be able to help you out

Sorry, I deleted the project and the repository because I tried to sync again. I have a new project with the same problem so I’m adding you there. If there’s anything more I can do just let me know, thank you!

Could you tell me the project name? (sorry, got snowed under)

I upgraded to 2021.1.3 again and somehow it worked, but thank you!

1 Like

Hi,
I echo this question as I have the same problem but the solution of upgrading to version 2021.1.3 does not seem to work…

I am working with Vs:
3.8.5 (default, Sep 3 2020, 21:29:08) [MSC v.1916 64 bit (AMD64)]
v.2021.1.3

I am uploaded the code from PsychoBuilder and also manually from GitHub but none of the options work. I keep having the “403 Forbidden” issue.
Any further idea?

Thanks in advance!

Have you tried with and without html in the run URL?

Thanks @wakecarter for such a quick answer!

Not sure that I understand what you mean…how can I remove the HTML?

What is the URL to the participant version of your study?

Hi,
Digging in your comment, I have managed to understand that it is also required to export the HTML to the github folder.

So what I do know is to load the task from the PsychoBuilder and export from the Psychocoder the HTML which generates the following files.

taskName.py
taskName-legacy-browsers.js
taskName.js
index.html

I am then able to avoid the error 403 but the tasks freezes at “Launching experiment”…
What am I doing wrong?

I press sync not export.

Have you looked at your experiment page on Pavlovia?

Hi,
These are the steps I follow:

  1. Code my script adapting one paradigm already running in Pavlovia
  2. Create Pavlovia account (my University has a full license)
  3. Sync GithHub and Pavlovia account
  4. From the PsychoBuilder I open the folder with my experiment (File.py, images (that i present))
  5. I click on “Sync with web project” to download the experiment in my Pavlovia - the experiment syncs well and I have it on my GithHub and Pavlovia account
  6. Open Pavlovia and try clink on “testing” the experiment.
  7. Error 403 appears…

Might I be forgetting something?