psychopy.org | Reference | Downloads | Github

Sudden extreme slowing (freezing) in Windows64 (standalone install)

Hi,

First of all, I would like to thank the devs for this great software!

recently I’ve been having this problem, where all of a sudden experiments seem to hang, freeze. Now it turns out it doesn’t hang entirely, but slows down extremely.

Others had this issue:

0.7654 WARNING We strongly recommend you activate the PTB sound engine in PsychoPy prefs as the preferred audio engine. Its timing is vastly superior. Your prefs are currently set to use [‘sounddevice’, ‘PTB’, ‘pyo’, ‘pygame’] (in that order).
55.8697 WARNING t of last frame was 4300.92ms (=1/0)
60.1690 WARNING t of last frame was 4299.29ms (=1/0)
64.4699 WARNING t of last frame was 4300.89ms (=1/0)
68.7697 WARNING t of last frame was 4299.82ms (=1/0)
73.0694 WARNING Multiple dropped frames have occurred - I’ll stop bothering you about them!
C:\Users\petso\Dropbox\sotepsypy\peter\asd_lastrun.py:73: RuntimeWarning: divide by zero encountered in double_scalars

  • frameDur = 1.0 / round(expInfo[‘frameRate’])*

after timing parts of the script I came to realize that the problem is in pyglet, see :

They mention the 4+s frametime, which is the same for me…

This mentions a fix at
https://groups.google.com/forum/#!msg/pyglet-users/7yQ9viOu75Y/JnusN0DsdscJ

I realize I had this problem before years before in an other pyglet application, when this patch fixed this.

I realize this is already implemented in the installed libraries. So now I am stuck…

This happens on 3 of my machines, All 64 bit windows Pro and Enterprise, locale is Hungarian and English and Hungarian.

Sometimes this just resets (restarting does nothing). One of the machines is a fresh install. I believe that this is due to some patches, but it would be nice to know which, or at least what kind of patches do this…

The error seems to be appearing after some non-working code change in the builder and a faulty run, but it also might be connected to screen sharing on the computer. Note that once it happens it doesn’t go away for days and multiple restarts, and then suddenly it works again (I assume some windows patches restore something somewhere). I also tried killing running processes and stopping windows security services.

I would appreciate any kind of suggestions…

1 Like

Amazingly I found a workaround for this. It is embarassingly simple: setting useFBO=False
LOL

Now I don’t really know what are the repercussions for this setting, it seems to be missing from the documentation of class psychopy.visual.Window.

I connect here another threads that recognised this:



Now it would be nice to know why this happens though…

Another advancement is that I refreshed my Intel Video Driver (Intel HD 4000 @ i7-3632QM) to the newest available version 10.18.10.5129 and now useFBO=True seems to be working on one computer at least (I will try the others also)