psychopy.org | Reference | Downloads | Github

useFBO option in Builder


#1

Hi All, I’ve found when trying to run a Builder-generated study on a relatively old PC that the experiment just basically grinds to a halt if the window is instantiated with useFBO = True.

Unfortunately, we can’t control the useFBO setting within Builder. The only solution seems to be to compile the script and manually edit the generated code. In this thread back in 2015:

https://groups.google.com/forum/m/#!msg/psychopy-users/vCsQHBGyC50/yr58ZRSJM00J

@jon suggested that useFBO = False should actually be the default, but that hasn’t been implemented (and would that still be the preferred option?)

Regardless, should we add the option within the Builder GUI to allow control over this setting?


#2

That’s strange, maybe the hardware has a hard time with floating point textures. I think the FBO is configured to use the highest possible color depth (I think it’s ‘GL_RGBA32F’).