Programs that worked earlier now take minutes to load and run slowly

OS: Win10
PsychoPy version: 3.1.5
Standard Standalone? (y/n): y
What are you trying to achieve?:
Our lab uses PsychoPy3 to run several cognitive tasks. In the past week, PsychoPy on 3/6 of our computers has stopped immediately running the programs, and instead takes up to 6 minutes for the first instructional screen to appear. For the 6 minute loading time, we see the grey background screen, and the program cannot be exited using the Escape key. The Builder opens normally, but the program slows to a crawl once the program is run. Once loaded, the program runs very slowly, and will frequently skip screens with timed offsets (e.g., the fixation cross will not appear before some stimuli).

All our programs were built using the Builder in PsychoPy3, and all of the computers are running the same version of PsychoPy (3.1.5 win64), so it is unclear why this issue is affecting some of our computers but not others. The program ran on all computers earlier this week, and we did not update PsychoPy in between the program running normally and the error occurring.

What did you try to make it work?: We have tried uninstalling PsychoPy3 and reinstalling.

What specifically went wrong when you tried that?: We had the same slow loading time problem. There are no error messages, it just loads and runs very slowly.

Update: We got the programs to work by uninstalling a recent Windows update (not a Security update). If other people encounter this issue, it is a quick fix. But people should look into why this error is occurring.

Can you tell which one it was? This issue keep come and go on our PC-s and it makes things very volatile…

Some have it some don’t, than it is back to normal for some reason, and then pops up again. Out of control…

Yes, more information about the fix would be highly appreciated!

We have the same problem described in the first post running the same Builder experiment on 10 PCs with very similar hardware and PsychoPy 2020.2.5 Standard Standalone. About half of them have the problem.

PsychoPy / Help / System Info only shows differences in the CPU and OpenGL info. However, both variants are featured both on working and non-working PCs, so they can’t be the direct cause.

CPU types:

  1. Processor: Intel64 Family 6 Model 58 Stepping 9, GenuineIntel; CPU freq (MHz): 3201.0; CPU cores: 4 (physical), 4 (logical)
  2. Processor: Intel64 Family 6 Model 42 Stepping 7, GenuineIntel; CPU freq (MHz): 3401.0; CPU cores: 4 (physical), 8 (logical)

Open GL info:

  1. Vendor: Intel; Rendering engine: Intel® HD Graphics 2500; OpenGL version: 4.0.0 - Build 10.18.10.4252
  2. Vendor: NVIDIA Corporation; Rendering engine: Quadro 600/PCIe/SSE2; OpenGL version: 4.5.0 NVIDIA 353.62

The full system info of a non-working PC is pasted below.

Paths to files on the system:
    userPrefsFile: C:\Users\User\AppData\Roaming\psychopy3\userPrefs.cfg
    appDataFile: C:\Users\User\AppData\Roaming\psychopy3\appData.cfg
    demos: C:\Program Files\PsychoPy3\lib\site-packages\psychopy\demos
    appFile: C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\PsychoPy.py

System Info:
     Operating System: Windows-10-10.0.17763-SP0
     Processor: Intel64 Family 6 Model 58 Stepping 9, GenuineIntel
     CPU freq (MHz): 3201.0
     CPU cores: 4 (physical), 4 (logical)
     Installed memory: 8470962176 (Total), 6183772160 (Available)

Python info:
     Executable path: C:\Program Files\PsychoPy3\pythonw.exe
     Version: 3.6.6 (v3.6.6:4cf1f54eb7, Jun 27 2018, 03:37:03) [MSC v.1900 64 bit (AMD64)]
     (Selected) Installed Packages:
         numpy (1.18.1)
         scipy (1.4.1)
         matplotlib (3.3.0)
         pyglet (1.3.3)
         PyGLFW (1.7.0)
         pyo 0.9.7
         psychtoolbox (3.0.16)
         wxPython (4.1.0)

OpenGL Info:
     Vendor: Intel
     Rendering engine: Intel(R) HD Graphics 2500
     OpenGL version: 4.0.0 - Build 10.18.10.4252
     Shaders supported:  True
     (Selected) Extensions:
         GL_ARB_multitexture: True
         GL_EXT_framebuffer_object: True
         GL_ARB_fragment_program: True
         GL_ARB_shader_objects: True
         GL_ARB_vertex_shader: True
         GL_ARB_texture_non_power_of_two: True
         GL_ARB_texture_float: True
         GL_STEREO: False
     max vertices in vertex array: 1048576