psychopy.org | Reference | Downloads | Github

subprocess.CalledProcessError: Command ‘[‘git’, ‘branch’, ‘–show-current’]’ returned non-zero exit status 129

I’ve noticed a reoccurring issue over the past week so I thought I’d create a thread bringing them together.

Here’s one with a solution from 2019 but a fractionally different error message:

@TParsons @jon

1 Like

Thank you @wakecarter for putting all of this together. I have an update on how I am exploring the error:
I am able to find the source files for the error messages when looking in the coder view. So I can access and inspect the code that is called builder.py and pavlovia.py etc. (where the errors are occurring) by looking in the source directory in coder view but I do not understand enough about how git works to know what it means.I hope someone with more knowledge of this code can spot what connects all of these errors.

1 Like

The error message concerning ['git' 'branch'] is an issue only in 2021.1.0 and fixed in the link below (you could apply that fix yourself or wait for the update, which will hopefully be today).

The older issue, regarding ['git', 'tag', '–show-current'] is more rare and a bit more puzzling. I think that might be something to do with removing the user preferences folder after opening the application but I’m not sure.

2 Likes

HI @jon i want to try fixing mine even though my issue is [‘git’, ‘tag’, ‘–show-current’]
what do i need to change in the coder script? i could not find in my script the changes you committed in the link

@chayabenyehuda according to your other post your error message is [‘git’, ‘branch’, ‘—show-current’] and that makes sense since you said it only started when you udpated.

The change required is not in your script though, it’s in the PsychoPy source code. You need to find the code in
C:\Program Files\PsychoPy3\lib\site-packages\psychopy\projects\pavlovia.py
and change it as indicated here:

OK, 2021.1.1 is available now with that bug fixed (with any luck!)

3 Likes

This worked for me. Thank you.

thank you! it works now!

This has worked for me also. Thank you so much @jon