psychopy.org | Reference | Downloads | Github

PsychoPy 2021.1.4: subprocess.CalledProcessError: Command '['git', 'branch', '--show-current']' returned non-zero exit status 128

Hello,

I saw this thread on this particular error message, however it looks like it was fixed on the newer versions. subprocess.CalledProcessError: Command ‘[‘git’, ‘branch’, ‘–show-current’]’ returned non-zero exit status 129 - #5 by jon.

I am using version 2021.1.4, however I still get this error. Does anyone know how I may be able to fix this issue?

Thank you,
Bahar

Not sure what causes the issue, but I might offer a somewhat blunt solution:

  1. Delete your project on gitlab.pavlovia.org (if there is any)
  2. On your hard-drive, go to the folder that contains your experiment, and delete the .git folder (you might need to show hidden files and folders for that)
  3. Close PsychoPy and open it again
  4. Try to sync

PsychoPy should offer you to create a new project then.

Thanks @thomas_pronk ! It does let me create a new project, but it still gives me the same error. Then, it creates a project with an empty repository, and if I try to sync with that it gives me the same error again. This happens whether I try to create/sync the project locally or from OneDrive (which is synced with and downloaded to the device). Do you know how I may be able to fix this?

Ah, if this might be a bug in PsychoPy, that goes over my head I’m afraid :). But before we pass it on, I’d like to give it a go myself. Could you share your experiment with me in a PM?

1 Like

Sure! Thank you very much!!!

(For other readers: @BaharSener sent me her experiment and I tried syncing it)

Syncing it from my computer (Windows 10) worked out fine. I do have a couple of suggestions though:

  • Try cleaning up your user preferences. See: Troubleshooting — PsychoPy v2021.1
  • Your pictures are really big; that could be a bit too heavy for participants with a slow device or connection. Consider recoding them to JPG, and perhaps reducing the resolution a bit. See: Media formats suitable for online studies — PsychoPy v2021.1
  • Don’t export to “html”, but leave that field empty. See Settings → Online → Output Path
  • The way you randomize pictures might make it hard for PsychoJS to preload them, but let’s first tackle the sync issue :slight_smile:
1 Like

Thank you very much @thomas_pronk !!!

I looked through the troubleshooting page and removed the cfg file. I then left the html field empty in the output path.

I still get the same error, is it possible that I am getting this because of my pictures? I’m confused on what I’m doing wrong since you were able to sync it!

Strange, but we’ll get there :). Maybe remove just the whole psychopy3 folder in %APPDATA%\psychopy3? (I’m assuming you’re running windows). Alternatively, I shared the version of your experiment that I managed to sync, maybe that one does work for you?

@thomas_pronk thank you for all your help on this. Weirdly, uninstalling and reinstalling PsychoPy solved it, but I’m sure it was also the removal of all those things. Now I’m able to sync so it’s time to tackle the other errors :smile:

Happy to read that. Good luck with the other bugs! :slight_smile:

1 Like