psychopy.org | Reference | Downloads | Github

subprocess.CalledProcessError: Command '['git', 'tag']' returned non-zero exit status 128

PC System version: Win 10
Psychopy version: Psychopy3.1.0 or (Psychopy3.0.6, Psychopy3.1.2)

Hello everyone,

Yesterday, I updated my psychopy to Psychopy3.1.2. Today, I found I cannot open the bulider interface. In the Shell, I get this error:
subprocess.CalledProcessError: Command ‘[‘git’, ‘tag’]’ returned non-zero exit status 128.
Then I have tried reinstalling the last version 3.0.6, restalling Python, however, the problem persists.

Could anyone give some suggestions how to deal with this problem?
Thank you in advance!

The errors are pasted as below:

Traceback (most recent call last):
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\app\_psychopyApp.py", line 518, in showBuilder
    self.newBuilderFrame()
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\app\_psychopyApp.py", line 504, in newBuilderFrame
    fileName=fileName, app=self)
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\app\builder\builder.py", line 1074, in __init__
    self.fileNew(closeCurrent=False)
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\app\builder\builder.py", line 1529, in fileNew
    self.exp = experiment.Experiment(prefs=self.app.prefs)
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\experiment\_experiment.py", line 88, in __init__
    self.settings = _settingsComp(parentName='', exp=self)
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\experiment\components\settings\__init__.py", line 156, in __init__
    + _versionFilter(availableVersions(), wx.__version__),
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\tools\versionchooser.py", line 186, in versionOptions
    for v in availableVersions(local=local)}),
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\tools\versionchooser.py", line 292, in availableVersions
    return _localVersions(forceCheck)
  File "C:\Program Files (x86)\PsychoPy3\lib\site-packages\psychopy\tools\versionchooser.py", line 201, in _localVersions
    env=constants.ENVIRON).decode('UTF-8')
  File "C:\Program Files (x86)\PsychoPy3\lib\subprocess.py", line 336, in check_output
    **kwargs).stdout
  File "C:\Program Files (x86)\PsychoPy3\lib\subprocess.py", line 418, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['git', 'tag']' returned non-zero exit status 128.

Hi @Westwood, I can recreate this error if I have an empty versions folder in my AppData path. If there is no git repo in that folder, the call to git tag will fail. It perhaps got emptied when you uninstalled/upgraded PsychoPy. Go to C:\Users\USERNAME\AppData\Roaming\psychopy3\ and delete the versions folder (it should be empty, but delete anyway if it is not). This will be recreated the next time you want to set the PsychoPy version in experiment settings. The AppData folder (as well as .git folders) are hidden, so if you cannot find the AppData folder, you need to make sure you have your folder settings in Windows Explorer set to view hidden files and folders (see Microsoft docs).

It works!Thank you so much!:smiley: