psychopy.org | Reference | Downloads | Github

Standalone application not starting; Win10


#1

Hi

This is a first-time install of the latest standalone version on the Psychopy website onto a Windows 10 machine. I get this error:

M:\>"C:\Program Files (x86)\PsychoPy2\python.exe" "C:\Program Files (x86)\PsychoPy2\Lib\site-packages\PsychoPy-1.84.1-py2.7.egg\psychopy\app\psychopyApp.py"
Traceback (most recent call last):
  File "C:\Program Files (x86)\PsychoPy2\Lib\site-packages\PsychoPy-1.84.1-py2.7.egg\psychopy\app\psychopyApp.py", line 60, in <module>
    app = PsychoPyApp(0, showSplash=showSplash)
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy-1.84.1-py2.7.egg\psychopy\app\_psychopyApp.py", line 107, in __init__
    self.onInit(**kwargs)
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy-1.84.1-py2.7.egg\psychopy\app\_psychopyApp.py", line 152, in onInit
    from psychopy.compatibility import checkCompatibility
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy-1.84.1-py2.7.egg\psychopy\compatibility.py", line 4, in <module>
    import psychopy.data
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy-1.84.1-py2.7.egg\psychopy\data.py", line 18, in <module>
    from scipy import optimize, special
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\optimize\__init__.py", line 233, in <module>
    from ._minimize import *
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\optimize\_minimize.py", line 30, in <module>
    from .lbfgsb import _minimize_lbfgsb
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\optimize\lbfgsb.py", line 44, in <module>
    from scipy.sparse.linalg import LinearOperator
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\sparse\linalg\__init__.py", line 116, in <module>
    from .matfuncs import *
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\sparse\linalg\matfuncs.py", line 19, in <module>
    import scipy.misc
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\misc\__init__.py", line 51, in <module>
    from scipy.special import comb, factorial, factorial2, factorialk
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\special\__init__.py", line 627, in <module>
    from ._ufuncs import *
ImportError: DLL load failed: The specified procedure could not be found.

Unfortunately I’m not experienced enough with Python or Psychopy to diagnose this - any ideas?

Many thanks
Chris


PsychoPy won't start
#2

Googling a bit, this seems to be a problem with scipy expecting numpy-MKL and the solution is usually to install that (see here). But this should not be up to you (the user), so it may be a bug.

When did the error occur? During installation? On first launch? When you ran an experiment? Looks like it happened when you launched Builder.


#3

Thanks for looking into this. The error occurs upon launching the application for the first time after installation has completed - it doesn’t get as far as opening the Builder.

I will have a go at installing numpy-MKL, and let you know how I get on. Incidentally, I just successfully installed PsychoPy on another Win10 PC, so it’s a problem specific to the first machine, which is a University-managed workstation.

Many thanks
Chris


#4

Hello

I tried to resolve this by following the manual installation steps as laid out on the PsychoPy website installation page, but with the exception that instead of installing numpy I installed numpy-MKL (I uninstalled the standalone PsychoPy that wasn’t loading before doing any this). Everything has installed ok except for PsychoPy itself - I get this error:

Collecting psychopy
Using cached PsychoPy-1.84.1.tar.gz
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File “”, line 1, in
File “c:\users\cab79\appdata\local\temp\pip-build-mjiwzm\psychopy\setup.py”, line 28, in
exec(vStr)
File “”, line 42, in
File “c:\users\cab79\appdata\local\temp\pip-build-mjiwzm\psychopy\psychopy_init_.py”, line 42, in
from psychopy.preferences import prefs
File “c:\users\cab79\appdata\local\temp\pip-build-mjiwzm\psychopy\psychopy\preferences_init_.py”, line 8, in
from . import preferences as prefsLib
File “c:\users\cab79\appdata\local\temp\pip-build-mjiwzm\psychopy\psychopy\preferences\preferences.py”, line 7, in
import configobj
ImportError: No module named configobj

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in c:\users\cab79\appdata\local\temp\pip-build-mjiwzm\psychopy\

I couldn’t find information online about someone having a similar problem to this. Any ideas?

Many thanks
Chris


#5

in a terminal run pip install configobj and try again


#6

Excellent, thanks - pip now installs PsychoPy. How do I now run PsychoPy - There is no icon I can click on like for the standalone version?

Cheers
Chris


#7

What I’ve tried is running PsychoPy from cmd by typing:

“C:\Python27\python.exe” “C:\Python27\Lib\site-packages\psychopy”

But what I get is:

C:\Python27\python.exe: can’t find ‘main’ module in ‘C:\Python27\Lib\site-packages\psychopy’

Is this a failure of the installation?

Many thanks
Chris


#8

I don’t often use Windows so can’t give a super definitive answer, but while we wait for others, one thing to consider is that the standalone includes its own python interpreter (python.exe) which would be installed somewhere under a folder like:

C:\Program Files\PsychoPy2

Whereas a system python might be under some place like:

C:\Python27

So if you’ve been manually installing things using pip, without specifying which python interpreter to use, I wonder if you’ve installed everything under the system python. Keep the possibility of two different python interpreters in mind as you figure this out.

Secondly, the builder is kind of a separate application. It looks like you tried to run the psychopy module hoping the builder would start. Out of curiosity, what happens when in your python shell you type 'import psychopy '? If nothing happens, that’s a good sign.

I think to run the builder from the command line you need to run a file similar to this one, from the troubleshooting page (http://www.psychopy.org/troubleshooting.html):

"C:\Program Files\PsychoPy2\python.exe" "C:\Program Files\PsychoPy2\Lib\site-packages\PsychoPy-VERSION-py2.6.egg\psychopy\app\psychopyApp.py" 

But again note that this example uses the stand alone interpreter, and runs the stand alone version. If you installed everything in your system python, you will have to adjust this command accordingly.

If that works and all is well, I think a quick Google can tell you where to put an icon/link on your system so that this file can be quickly run from the start menu.


#9

Hi Daniel

Thanks so much for taking time to consider what’s going on here.

I am indeed trying to use the system python at C:\Python27, and this is where everything was pip-installed. Typing “import psychopy” into the system python does nothing (i.e. no errors) so that seems ok.

I did try to open psychopy in the way you suggest but in my system-python installed version of psychopy, within the “site-packages” folder, there is no folder with a .egg at the end. I have the following beginning with “psychopy…”:

psychopy
psychopy_ext
psychopy_ext-0.6.0.4-py2.7.egg-info
PsychoPy-1.84.2.dist-info

So I’ve tried the following from the “psychopy” folder (first one in the above list) and got the following error:

"C:\Python27\python.exe" "C:\Python27\Lib\site-packages\psychopy\app\psychopyApp.py"
Traceback (most recent call last):
  File "C:\Python27\Lib\site-packages\psychopy\app\psychopyApp.py", line 10, in <module>
    from psychopy.app._psychopyApp import PsychoPyApp, __version__
  File "C:\Python27\lib\site-packages\psychopy\app\_psychopyApp.py", line 33, in <module>
    from . import projects
  File "C:\Python27\lib\site-packages\psychopy\app\projects.py", line 17, in <module>
    import requests.exceptions
ImportError: No module named requests.exceptions

So, either I’m not running the correct version of psychopy, or there is something else wrong with the installation, I would guess.

I would really much prefer to use the standalone version of psychopy, as but as my original message shows, this is not working on my computer. I wonder if there is a way of tinkering with the standalone installation to get it to work (e.g. somehow replacing numpy with numpy-MKL), rather than going via manual install?

Many thanks
Chris


#10

Yes this all sounds very annoying, and I feel for you. If you want to try to use the standalone, I believe you can install missing packages into the standalone interpreter, by giving the full path to that python.exe instead of just running “python”. You may have to install pip with that interpreter too? I’d give it a Google.


#11

But taking a step back, is there a tech department you could ask for clues about why it’s not installing correctly in the first place? Do they have some type of software running that could impose restrictions on how things are installed? I fear you’re going down a rabbit hole chasing dependencies.


#12

You were right to try (and if you put that into a “shortcut” then it looks like an application, which is exactly what standalone psychopy does in the start menu:

"C:\Python27\python.exe" "C:\Python27\Lib\site-packages\psychopy\app\psychopyApp.py"

The error message ImportError: No module named requests.exceptions is very much like the one about configobj, right? So try the same solution :wink:


#13

Are you absolutely sure you want to continue using that Python installation? As soon as you need to install mathematical packages like the NumPy/Scipy stack and Pandas (which is used in some parts of PsychoPy), you may run into problems. I would strongly suggest to use a scientific Python distro to start with, e.g., Anaconda.

Edit:


#14

Excellent! Thanks everyone for your help. I got it working in the end by following Richard’s advice and doing an Anaconda install. All seems well so far…

Kind regards
Chris


#15

3 posts were split to a new topic: Standalone version does not boot up


#16

hi all, kind of related to this thread:
I have version StandalonePsychoPy-1.85.0rc5-win32 on Windows 7. I am using the same short cut, but there’s no directory site-packages\PsychoPy-1.85.0rc5-py2.7.egg/ at all. The scripts, including psychopyApp.py, are in Scripts/. I just created the subfolder:
Lib\site-packages\PsychoPy-1.85.0rc5-py2.7.egg\psychopy\app
and copied psychopyApp.py there. Then it works. But it feels wrong anyway.


#17

C:\Users\Vishnu K>“C:\PsychoPy2\python.exe” “C:\PsychoPy2\Lib\site-packages\PsychoPy-1.84.2-py2.7.egg\psychopy\app\psychopyApp.py"
Traceback (most recent call last):
File “C:\PsychoPy2\Lib\site-packages\PsychoPy-1.84.2-py2.7.egg\psychopy\app\psychopyApp.py”, line 10, in
from psychopy.app.psychopyApp import PsychoPyApp, version
File "C:\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy_init
.py”, line 42, in
from psychopy.preferences import prefs
File “C:\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy\preferences_init_.py”, line 8, in
from . import preferences as prefsLib
File “C:\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy\preferences\preferences.py”, line 232, in
prefs = Preferences()
File “C:\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy\preferences\preferences.py”, line 43, in init
self.loadAll()
File “C:\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy\preferences\preferences.py”, line 135, in loadAll
self.userPrefsCfg = self.loadUserPrefs()
File “C:\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy\preferences\preferences.py”, line 170, in loadUserPrefs
encoding=‘UTF8’, configspec=self.prefsSpec)
File “C:\PsychoPy2\lib\site-packages\configobj.py”, line 1229, in init
self._load(infile, configspec)
File “C:\PsychoPy2\lib\site-packages\configobj.py”, line 1318, in _load
raise error
configobj.ParseError: Invalid line (u’\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00’) (matched as neither section nor keyword) at line 1.

My psychopy is not starting… i tried reinstalling the software twice and also i reinstalled python. As per troubleshooting method in the website, I am getting this type of error. Till yester psychopy was working in my system. Kindly help me out since its an emergency.


#18

This can happen because of an outdated DLL elsewhere on the system which is mistakenly being loaded:

https://groups.google.com/forum/#!topic/winpython/gHAaJ-pvj8s

A common reason for those errors is an outdated LIBMMD.DLL (or less
commonly LIBIFCOREMD.DLL) in the %WINDIR%\System32 or %WINDIR%\SysWOW64
directories. Some programs mistakenly install the Intel runtime DLLs there.

In my case, I just had to remove these DLLs and ufuncs imports fine :slight_smile:

Let me know if this worked for you.