psychopy.org | Reference | Downloads | Github

Unable to Start PsychoPy

Hello,

I have just downloaded PsychoPy for the first time. I am using the standalone windows installation. On one of my computers I experienced no issue, but on this second computer I am having difficulty.

Unlike others who have posted before, I do not see a splash screen or an icon does no appear in my task bar. Task manager does not show any software open at all.

Here is the result of running: “C:\Program Files\PsychoPy2\python.exe” “C:\Program Files\PsychoPy2\Lib\site-packages\PsychoPy-1.84.2-py2.7.egg\psychopy\app\psychopyApp.py

oPy2\Lib\site-packages\PsychoPy-1.84.2-py2.7.egg\psychopy\app\psychopyApp.py"
Traceback (most recent call last):
File “C:\Program Files\PsychoPy2\Lib\site-packages\PsychoPy-1.84.2-py2.7.egg\p
sychopy\app\psychopyApp.py”, line 10, in
from psychopy.app.psychopyApp import PsychoPyApp, version
File "C:\Program Files\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\p
sychopy_init
.py", line 42, in
from psychopy.preferences import prefs
File “C:\Program Files\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\p
sychopy\preferences_init_.py”, line 8, in
from . import preferences as prefsLib
File “C:\Program Files\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\p
sychopy\preferences\preferences.py”, line 232, in
prefs = Preferences()
File “C:\Program Files\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\p
sychopy\preferences\preferences.py”, line 42, in init
self.getPaths()
File “C:\Program Files\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\p
sychopy\preferences\preferences.py”, line 94, in getPaths
self.paths[‘userPrefsDir’] = join(os.environ[‘APPDATA’],
File “C:\Program Files\PsychoPy2\lib\os.py”, line 425, in getitem
return self.data[key.upper()]
KeyError: ‘APPDATA’

I am unable to find a PsychoPy2 folder in any of the App data locations on my PC. Yes I have hidden files visible.

Hope someone can provide some insight!

That’s very weird. It suggests that the APPDATA environment variable doesn’t exist on your machine. What version of windows is this? I imagine that would cause all sorts of other problems with the computer though. :-/

If you go to a terminal and type C:\Program Files\PsychoPy2\python.exe you might be able to help us find an alternative way to find your appdata folder though. COuld you run these lines from the python prompt?:

from win32com.shell import shellcon, shell
print shell.SHGetFolderPath(0, shellcon.CSIDL_APPDATA, 0, 0)

Hello Everyone,

I used psychopy 1.84.2-win32 on my professional computer for months now, and suddenly today it is unable to start psychopy. I tried different tips like search if the window was hidden, but nothing work (and my personal computer had the same problem, but since the biginning)… It seems like there is something wrong with windows pc !

I tried to uninstall then install again, nothing works. Do you have any solution ?

Have a nice day,

Clémentine

PS : I don’t know if it’s the same problem in this topic, but maybe it fit.
PSS : Sorry for my english

Thanks for helping me out with this issue jon!

This is a Windows 7 PC. I do not use it very often but it is the only PC in my office that has a parallel port at the moment. I believe it was originally a Windows Vista PC that was upgraded to Windows 7 years ago.

The lines you requested ran in python yield the following result:

C:\Users\jmiller\AppData\Roaming

It appears that python has no issue in locating but there is nothing from PsychoPy installed in that location.

Searching my entire C drive did not yield the config files that should have been present in APPDATA

Did you try “Cleaning preferences and app data”? This seems to have fixed the problem you are experiencing for most members.

http://www.psychopy.org/troubleshooting.html#cleanprefs

OK, it isn’t a surprise that psychopy hasn’t yet put anything in that location as long as it exists. The issue, as I said, is that on your machine the environment variable APPDATA has been deleted for some reason. It should be there on all recent versions of Windows but for some reason it has been lost on your computer (I’ve no idea who or what would delete such a thing!).

Options for you are:

  • create the APPDATA environment variable again
  • hack psychopy to use the shell command above rather than the environ[‘APPDATA’]

Jon

Thanks for figuring out the problem. I verified in the registry that my user account has absolutely no environment variables set, in fact there isn’t even a “User Shell Folders” folder in the normal location.

I am going to track down a different PC with parallel port that I know has proper environment variables set instead of dealing with this headache!

Thank you again for all your help!

Hi there!

I’ve downloaded the standalone PsychoPy Windows version for the first time. I have Windows 8.1 and I can see the PyschoPy folder in my Program Files folder. I can’t figure out how to start/ launch the application. Do I need to download something else? I’m a complete novice when it comes to programming and coding and I would be very grateful for any help with this.

I know that this post is more than two years old, but in the interest of posterity, I’d like to share something that has worked for me on two different Windows computers. It appears that the Windows version of the standalone download includes all of the necessary files to run PsychoPy but does not include the PsychoPy shortcut that would normally make it easy to find and run the program. You can make your own shortcut by doing the following:

  1. Create a new shortcut (right-click and select “Create new shortcut” or similar language) to the following file in the PsychoPy folder: Lib/site-packages/psychopy/app/psychopyApp.py
  2. Double-click the shortcut. Your computer should prompt you to specify a program to open the shortcut. Select pythonw.exe in the PsychoPy folder.
  3. If the program does not open automatically, try double-clicking the shortcut again. This should open PsychoPy.