psychopy.org | Reference | Downloads | Github

Standalone PsychoPy3 not starting

Hi,

I am new to PsychoPy (and Python in general) and I am experiencing some trouble after I’ve only just installed the current standalone version of PsychoPy3: PsychoPy simply won’t start.

I’ve re-installed it, still no change. Also, I’ve tried following advise found in similar threads, however, I cannot make it work for some reason. Cleaning preferences and app data also proves to be difficult as I cannot find userPrefs.cfg nor appData.cfg as suggested in the Troubleshooting section.

I ran the PsychoPy app with command prompt using the following line of code (as has been suggested for similar problems):

C:\Program Files (x86)\PsychoPy3>python.exe -m psychopy.app.psychopyApp

This yields the following message:

Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\runpy.py”, line 193, in _run_module_as_main
main”, mod_spec)
File “C:\Program Files\PsychoPy3\lib\runpy.py”, line 85, in _run_code
exec(code, run_globals)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\psychopyApp.py”, line 104, in
main()
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\psychopyApp.py”, line 100, in main
start_app()
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\psychopyApp.py”, line 28, in start_app
app = PsychoPyApp(0, showSplash=showSplash)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app_psychopyApp.py”, line 182, in init
self.onInit(testMode=testMode, **kwargs)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app_psychopyApp.py”, line 201, in onInit
splashImage = wx.Image(name=splashFile)
wx._core.wxAssertionError: C++ assertion “wxString::Format(”%.3f", 1.23).find(str) != wxString::npos" failed at …\src\common\intl.cpp(1648) in wxLocale::GetInfo(): Decimal separator mismatch – did you use setlocale()?If so, use wxLocale to change the locale instead.

However, I cannot really make sense of this, so any help is really appreciated. If anyone has any suggestions on how to solve this problem, I’d be very thankful!

Hi @schmit22, there seems to be a bug either in PsychoPy or one of its dependencies; anyway, this problem has been reported (and resolved) before:

Thank you! No idea why I didn’t find the original thread myself. However, it’s working now.