| Reference | Downloads | Github

PsychoPy won't start

Hi everyone,
I have been used PsychoPy Standalone 1.82.01 (I think) for a long time under windows 8.1, and it worked well, until I upgraded to the newest version (1.85.0). After installation (of course, after the previous version have been removed), the app does not start, only the splash screen appears and then goes away. I have reinstalled it several times, also tried other newer versions (1.84.01, 1.84.02), deleted the appData.cfg, nothing has changed. There is no hidden window issue, and the cmd does not give any error messages. Although, there is no such folder like “PsychoPy-VERSION-py1.85.0.egg” inside folder “site-packages”, only a similar one (see attached img below).

Thank you for your help in advance,

One thing is that I don’t believe the way you tried to start it from the command line is correct. I’m not a frequent Windows user so someone correct me if I’m wrong, but I think you have to put the two lines you entered on one single line, with a space separating them. Maybe this way could get some helpful error messages.

Oh yes, you’re absolutely right, thank you! I don’t have a clue why I have thought I should do differently. Here comes the error message. And I don’t know why I don’t have that dict.

Well that error makes me think we still haven’t successfully run psychopy from the command line. It looks like the first part (the call to psychopy’s Python interpreter, python.exe) is working, but path to the app isn’t being entered correctly.

I would use the “tab” key to have the command line help you enter the correct file name: you start entering part of a folder or file name, and hit “tab” to have it autocomplete the name for you, and keep doing so until the whole name is entered. Hopefully that will help.

EDIT: You may have to hit the tab key a couple of times if there are several folders or files that start with the same letters.

It’s very weird, but the case is (as I wrote in the original post) I do not have the folder inside the “site-packages” which should include the “psychopy\app\” parts. As I see, it should have to end with “.egg”, but I only have one with ending “.egg-info”, and you can see in the 1st post what does it consist of. Do I miss something badly?
I also have tried to start a search for the “” file, and got no result.

Sorry I haven’t responded, I’m going someone else will since now I’m not sure where the problem could be, hopefully someone else will respond soon.

But just to clarify for others, there is no file anywhere within that folder?

Yeah, inside PsycoPy2/Lib/site-packages, there is only that PsychoPy-1.85.0-py2.7.egg-info folder which is similar to one we need, but there are only 4 .txt files and a file called PKG-INFO in it.
I have reinstalled the app again, checked that the uninstallation have really removed everything, and it did, but still no changes in the situation.

Later tonight I’ll try to install the standalone on a Windows machine and will see what it’s supposed to look like.

Ok so the psychopyApp file is not in the egg, but here:

"C:\Program Files (x86)\PsychoPy2\Lib\site-packages\psychopy\app\"

So run this to open it from the command line to start it, and hopefully we can finally get a useful error message:

"C:\Program Files (x86)\PsychoPy2\python.exe" "C:\Program Files (x86)\PsychoPy2\Lib\site-packages\psychopy\app\"

I’m not sure when this changed happened (since this differs from the doc page in Troubleshooting), but we’ll have to update that.

Yes, thank you very much, we finally get the error message:

C:\Windows\System32>“C:\Program Files (x86)\PsychoPy2\python.exe” “C:\Program Fi
les (x86)\PsychoPy2\Lib\site-packages\psychopy\app\"
Traceback (most recent call last):
File “C:\Program Files (x86)\PsychoPy2\Lib\site-packages\psychopy\app\psychopy”, line 62, in
app = PsychoPyApp(0, showSplash=showSplash)
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\app_psychop”, line 118, in init
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\app_psychop”, line 163, in onInit
from psychopy.compatibility import checkCompatibility
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\compatibilit”, line 4, in
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\”, li
ne 18, in
from scipy import optimize, special
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\optimize__init”, line 233, in
from .minimize import *
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\optimize_minim”, line 30, in
from .lbfgsb import minimize_lbfgsb
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\optimize\lbfgsb
.py”, line 44, in
from scipy.sparse.linalg import LinearOperator
File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\sparse\linalg_
.py", line 116, in
from .matfuncs import *
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\sparse\linalg\m”, line 19, in
import scipy.misc
File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\misc_init
y”, line 51, in
from scipy.special import comb, factorial, factorial2, factorialk
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\special_init”, line 627, in
from ._ufuncs import *
ImportError: DLL load failed: The specified procedure could not be found.

And I think I have ended at the same problem like Standalone application not starting; Win10. But unfortunately, I still can’t resolve it. (Now I have installed Anaconda, as it looked like to be a solution, but I don’t really know what is it and what should I do with it.)

So again I’m not a regular Windows user, but looking at some of those links, it looks like Anaconda is a science-oriented distribution of python, and it has its own package manager (which is a great thing once you get familiar with them!), meaning you can use it to install / update / remove packages (which are just collections of software).

So I would uninstall Psychopy if you haven’t already, and it seems like you run these commands from the Anaconda prompt to get Anaconda to install psychopy for you:

conda install wxpython
pip install pyglet psychopy

I have installed psychopy via Anaconda the way you wrote, it was successful, now it launches from the command line, no more error message, but… I haven’t found out how to launch it in “normal” way, and from the command line, it does not really start my scripts (I don’t know if it was normal).Thank you for your conscientious help, thanks for giving so immediate and adequate answers for my every single problem (despite you are not Windows user), you’re awesome! But I need it to work for tomorrow, so now I think I give up for a while using the latest version, I have installed version 1.83.01 and it works perfectly. Maybe I will try again for my next experiment …:slight_smile:

Haha, I understand the frustration, but you were at the end!

Oh well, for the future, I assume all one would have to do is add a link to the start menu.

Maybe @jon wouldn’t mind quickly outlining how one could make a start menu shortcut for Psychopy (keeping in mind that this is an Anaconda installation)?

Yes, Dan is correct. In the new release (1.85.0) this has changed slightly to be simpler. No version number is in the folder name any more (because it was installed using pip instead of easy_install)

Why the scipy ufuncs error is occurring I don’t know. Will look into it.

I know very little about anaconda and not planning to start learning! :wink: I prefer to get Standalone working properly instead.

I think I had this same problem for ages, and it took weeks to figure out it wasn’t a psychopy problem but something to do with WIndows hiding the window. Try the steps below, and if it works I’d keep them handy - it still happens to me every few days for no apparent reason that I can figure out so I have the steps stuck to a post-it on my laptop!

Getting Your Hidden Window Back with Cascade Windows
The easiest way to get back a hidden window is to just right-click on the Taskbar and select “Cascade windows”.

If that doesn’t work, proceed with the keyboard trick below.

Getting Your Hidden Window Back with the Keyboard Trick

There’s a simple trick to get around this. First make sure you’ve
alt-tabbed to the window, or clicked on it once to bring it into focus.
Then right-click on the taskbar and choose Move.

Note: If you’re using Windows 8 or 10 you might have to hold
down the SHIFT key before right-clicking in order to get the Move menu
item to show up.

At this point, you should notice that your cursor changes to the “Move” cursor, but you still can’t move anything.

Just hit any one of the arrow keys (Left, Right, Down, Up), move your
mouse, and the window should magically “pop” back onto the screen.

Note: For keyboard savvy people, you can just alt-tab to the window,
use Alt+Space, then M, then Arrow key, and then move your mouse.

Apparently Damien knew of one suggested fix for this, see the link below: