psychopy.org | Reference | Downloads | Github

Psychopy wont start

Hi,

All of a sudden psychopy will not launch. The splash screen appears and then disappears. I have tried to re-install psychopy also I have deleted the psychopy folder in “c:\users<user>\appdata\roaming”. none of these have worked. OS is windows 10. When i try and run psychopy from the command line I get the following error message:

C:\Program Files (x86)\PsychoPy2>python.exe “C:\Program Files (x86)\PsychoPy2\Lib\site-packages\PsychoPy-1.84.2-py2.7.egg\psychopy\app\psychopyApp.py"
Traceback (most recent call last):
File “C:\Program Files (x86)\PsychoPy2\Lib\site-packages\PsychoPy-1.84.2-py2.7.egg\psychopy\app\psychopyApp.py”, line 60, in
app = PsychoPyApp(0, showSplash=showSplash)
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy\app_psychopyApp.py”, line 107, in init
self.onInit(**kwargs)
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy\app_psychopyApp.py”, line 152, in onInit
from psychopy.compatibility import checkCompatibility
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy\compatibility.py”, line 4, in
import psychopy.data
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy-1.84.2-py2.7.egg\psychopy\data.py”, line 18, in
from scipy import optimize, special
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\optimize_init_.py”, line 233, in
from .minimize import *
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\optimize_minimize.py”, line 30, in
from .lbfgsb import minimize_lbfgsb
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\optimize\lbfgsb.py”, line 44, in
from scipy.sparse.linalg import LinearOperator
File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\sparse\linalg_init
.py", line 116, in
from .matfuncs import *
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\sparse\linalg\matfuncs.py”, line 19, in
import scipy.misc
File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\misc_init
.py”, line 51, in
from scipy.special import comb, factorial, factorial2, factorialk
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\scipy\special_init_.py”, line 627, in
from ._ufuncs import *
ImportError: DLL load failed: The specified procedure could not be found.

If anyone can help that would be great.

Martin

I have run into a similar problem before. For me, it occured because another program had installed a DLL (c:\windows\SysWOW64\libmmd.dll in my case) that was causing problems for scipy. See this thread for more info.

2 Likes

Worked

Thanks very much

I renamed the .dll file and it worked!
Thank you!

I am having the same issue: PsychoPy will not launch from the start menu, the task bar, or even the program folder. I tried renaming / deleting libmmd.dll as well, and that didn’t help.

Interestingly, though, I can open PsychPy if I Run as Administrator, instead of through my normal user profile – but only when I restore libmdd.dll to its original place / name.

Anybody have a different solution to this problem?

Perhaps related: starting a few weeks before this not-launch problem, PsychPy began opening itself offscreen. With a bit of wrangling I can bring it back into my workspace, but none of my other programs have this problem.

Hi there, i encountered the same problem when i installed psychopy standanlone in WIN7. I searched on the web and finally solved the problem.
Just share my solution here.
The major reference is this:

What i do is go to Python Extension Packages for Windows - Christoph Gohlke ,
manually dowload the numpy.mkl whl which corresponding to the python in my computer(although psychopy standalone did not need to install python, but we need pip to ‘unzip’ the whl file).
Then pip install the whl file.
Go to the installed folder (for me, it’s C:\Users…\AppData\Roaming\Python\Python38\site-packages\numpy),
copy all the files and replace the numpy in the psychopy standalone location (for me, it’s C:\Program Files\PsychoPy3\Lib\site-packages\numpy).
Then I can open psychopy.