psychopy.org | Reference | Downloads | Github

Software platform and version not recognised in Pavlovia - depending on device

URL of experiment:

Description of the problem:
When uploading my experiment to Pavolvia the software platform and version are not recognised. The program and all code elements are fine. A colleague of mine uploaded it and there the version and software appeared - the program ran online.
I uninstalled PsychoPy and replaced it with the new version but the same error appears. When I compiled the JS script, no error messages appeared.

Does anyone have any suggestions? Until yesterday, I was able to upload my programs and then suddenly the error started emerging.
I’m running it all on MacOS Big Sur 11.2.3

Hey! Sorry for that; it’s a known issue which we’ll fix soon. Besides it being a bit strange that Platform says 0, it shouldn’t affect the actual experiment.

Hello @Inga,

This is due to us changing the way we are packaging the PsychoJS library.
I’m fixing this as we speak. It will be sorted very shortly.

Alain

1 Like

Hey, okay! Good to hear that it’s not only me.

The problem is that I cannot pilot or run the experiment. Offline it works perfectly fine. But I need it as an online experiment.

Best,
Inga

That is rather odd. Can you share with me the full path of your experiment?

Hi @apitiot !

Great to hear. Thank you very much!

Will there be any kind of announcement as soon as it’s fixed? Otherwise I’ll try it next week again.

Best,
Inga

Wow. I’m really sorry. Yesterday, it got stuck on initialising experiment or didn’t do anything.
Now it is working despite the un-recognised platform and version.

Thank you very much!! I should have tried that earlier.

1 Like

Phew, that is reassuring!
All the same, I’ll have the platform estimation sorted shortly.

2 Likes