Run study online button on psychopy - stuck on initializing page

URL of experiment: Headline_Task_9_6 [PsychoPy]

Description of the problem: I have been collecting data for this study for a couple of weeks now using Pavlovia, and it seems to be running fine with the exception of a random crash here and there. However, I realized that my instruction slide had some incorrect information, so I went into builder to update it and synced the changes. However, the changes were not reflected on Pavlovia even though the sync was successful and the changes were reflected on GitLab. I know that this is a common issue and it has happened to me before. Clearing my cache and browsing history did not work, and neither did incognito mode or trying from a different laptop. So, I did what I normally to do resolve the issue and changed my experiment from running to inactive and back again. The last updated date changed to today, but the change still was not reflected when I piloted the experiment.

I saw another user with the same issue who launched the study from PsychoPy using the “run the study online (with” button in order to make the changes sync. I tried doing this, but the experiment was stuck on the initializing page and, upon looking at the developer tools in my browser, I got this error 5 times, with a different link for each instance: failed to load resource: the server responded with a status of 404 (). I’m not sure why this is happening because when I run and pilot the study from Pavlovia itself it works fine. Additionally, I have a second phase of the experiment that is essentially identical to the first, and launching it online from builder worked perfectly and it also updated the online version of the instructions just as the other user said it would. I’m not sure why my phase 1 isn’t launching properly or updating.

I don’t really care if I can’t launch the study from PsychoPy itself at the end of the day, I just need my instructions updated. If anyone knows why the Run study online button is giving me issues or if anyone has another method of making the changes sync, I would appreciate it!

After looking more into the issue, I noticed that my html folder on GitLab contains a folder called resources, which has all my images it in. This folder does not contain the updated version of the instructions slide, so that is probably why Pavlovia is not registering the change. However, I have no idea what to do about this, since I definitely did update the resources in builder before syncing, and I don’t know why this would mean I can’t run online from builder but can from Pavlovia dashboard.

Ok, I just manually updated the resources folder in the html folder locally and synced again and it worked! The instruction slide has updated now. Running online by pressing the button in builder still doesn’t work, but piloting from Pavlovia does and participants can run from the link I provided, so it seems like the main issue has been resolved.

I would recommend avoiding the html folder in future.