Brand new experiment stuck on initializing in Pavlovia

I’ve been struggling to get my experiment to run on Pavlovia. So to figure things out, I made a brand new, empty experiment, and tried to get that to run on Pavlovia, but no luck. The experiment is stuck on “initialising” and the console says “Failed to load resource: the server responded with a status of 404 ()”.

The exact steps I took:

  1. Open Psychopy and save my fresh, never touched experiment.
  2. Try to run the experiment both in Psychopy and in PsychoJS on a local browsers - this works
    Following the steps here:
  3. I log into my Pavlovia account - successfully
  4. I sync my project which prompts me to create a project, which I do.
  5. On Pavlovia, I change the status to piloting
  6. I pilot the project

And then it’s stuck. I have tried changing the status back and forth from inactive to piloting. I have checked the code on gitlab - everything is there.

Why is it not working?

I’ve done extensive googling, and whenever someone else has this problem, it’s some issue with their particular project. But I have done nothing to my project at all, it’s the default, empty project. I’ve tried all the solutions I could find online, but nothing worked.

Btw, I’m using the newest PsychoPy standalone package, so 2023.2.3

I would appreciate some help.

When you change the status on Pavlovia does it give you the correct version number on the project page?

Check that the name of the file matches the name of the experiment in Experiment Settings and that the output path in the online tab is blank