PsychoPy stuck on 'Pushing to Pavlovia for the first time', becomes unresponsive

Hey, so I’m trying to upload my experiment onto Pavlovia and I can’t get past ‘Pushing to Pavlovia for the first time’. It freezes there and becomes unresponsive after a while. I’m not too sure what else to try. Please help.

I’m using the latest PsychoPy version, pulling from the right folder, and also exported html before upload.

@Carina_Cretu I have the same problem. Before, I was using the 2020 version of psychopy and it worked there.

I’m not sure if this would also solve the problem for you, but what I did was not to press on “run the study online” button and to press on “sync with web project” on the builder mode.

Although there’s actually no project to sync with pavlovia.org, as I was creating the study online for the first time, if you press on “sync”, then it automatically guides you to create a new project and that works!

I’ve also had the same problem before, and read it somewhere in the forum that you shouldn’t “run” the project online, but to “sync” the project from the beginning.

I hope this works for you!!

Hi @MIJUNG, thanks for chiming in! I’ve actually always been using the sync button to create my projects online so this won’t be my solution unfortunately :disappointed:.

Frustrating! I’m on a bit of a time constraint as well and have no idea how to navigate this. Does it still work with older versions for you? @Mel499 Thanks!

Thanks for your suggestion @MIJUNG !
Until now, I only tried to press the “sync with web project” button and to go through the menu bar (Pavlovia…), but I never tried the “run the study online” button right away. I just tried it out and the project seems to sync now. Though you suggested not to use it, weirdly for me this was the solution :smiley: Thank you so much for the hint!

Hang on, so for you @Mel499 it worked pressing Run Study Online instead of Sync? I’ll try that too!

@Carina_Cretu Yes that worked for me. However, I still sometimes has issues with the synchronization, as sometimes only the psychopy version of the project and not the javascript one gets updated. I figured that always trying another button or opening the JS file in the program while synchronizing somehow helps. Weird, but it works for me :smile:

Hi dear Carina,

The only solution for me was to downgrade my Psychopy version to 2021.1.1, and now everything works fine and perfect ! That error is a bug in the newest versions, as I had the latest version (2022.2.4). So, try to change your version, uninstall and install everything again, and create a new project on Pavlovia.

I hope that works for you !

1 Like