Qualtrics survey "condition" not autofilling in psychopy experiment

URL of experiment: https://run.pavlovia.org/sydperry/hnp-1/html

Description of the problem:
I am about to run an experiment where participants are recruited via Prolific then sent to Qualtrics (where the participant ID is auto filled) and are randomly assigned one of eight conditions during the survey and are later routed to the Psychopy experiment and when finished are taken back to the recruitment program Prolific. The problem is that when I get taken to Psychopy the participant and condition field are not getting auto filled, as they should be. I’m not really sure what I need to add to ensure things get auto filled so any help is appreciated.

Can you show an example of a URL to your experiment coming from Qualtrics? I suspect that the URL variables don’t match the expInfo box


That doesn’t contain values for participant and condition.

Have a look at this guide

link in redirect section in survey termination on Qualtrics^^

link in Psychopy experiment^^

I’ve tried to follow the steps. Do these look right? I’m unsure of whether the name should be Prolificid or PROLIFICPID

The ID coming in from Prolific is presumably being saved as PROLIFIC_PID.

However, you are giving your participants an opportunity to edit their ID.

Are you saving that to a new embedded variable (Prolificid)?

Your URL is missing condition

The route I have setup from Prolific to Qualtrics allows the Prolific ID to be auto filled (there is embedded data involved).
new link ^^

I don’t understand how to add condition parameters to links. They’re embedded in Qualtrics but how do I get hem to show up in the conditions field in the experiment.


if your embedded variable is called condition in Qualtrics.

1 Like

It works! Thank you so much for your help!

so everything was working and now the Prolific ID won’t fill. I’m wondering if it has to do with me not being able to have the $ to be in front of my URL on Psychopy in the experiment settings/online section. It makes the link turn red and it won’t save like that. Do I absolutely need this component?

i fixed the auto fill but im still wondering if not having a $ will cause problems in the future

A dollar sign certainly was needed in version 2020. The most common error is accidentally using smart quotes. Please could you show a screenshot of your completed URL


You have unbalanced quotes. I would add a dollar sign followed by double quotes at the start

It’s still saying I can’t do that.

Now you look like you’ve got smart quotes (around participant). Delete and retype all of your quotes.

I got the $ symbol to be added in the beginning with no error shown (red highlighting) then retyped all of the quotes but then I got this error message when trying to sync.

Please could you show a screenshot of your URLs now?