Online experiment stuck at ‘Initialising the experiment…’

URL of experiment:
Gitlab repository: Bao Wei / S2_EX1_Programme · GitLab
URL of the experiment: study2_ex1_programme [PsychoPy]

Description of the problem:
This experiment successfully run on the Pavlovia for a week on the last month, but this month suddenly not work. I am wonder if there is any change on the Pavlovia? I deleted the previous version experiment and put the experiment in another location of my computer and reupload the experiment in a new gitlab repository. However, it still not work, the error messages in the picture. I have checked the path of resource, but the online experiment still have error message. Any help would be very appreciated.

Hi, can you try adding your images as additional resources (see below) and resync it to see if it works?

Hi suelynnmah, thank you for your reply. I have already added all resources in the Online tab and double checked it, but the online experiment still not work. It is very strange that my online experiment working perfectly on Pavlovia in half a month ago, this problem just happened about two or three days ago.

I actually went past the initialising screen and got an error at the stroop practice image. I checked how you were calling the image


and it uses information from the dialog box. I just populated the box and it runs fine so I’m guessing you just need to populate the key_balance_stroop task every time you’re trying out your task

suelynnmah, thank you for your suggestion. But I can not past the initialising screen before the dialog box on both Chrome and Edge browser. And I tried to Pilot the experiment online, it still reported the same error messages as in picture. Is this about my network connection problem?

Can you try clearing your cache to see if it changes anything?

I clear all cache in brower setting, it still reported sames error messages and could not pass the initialising screen. :sob:

It seems to be complaining about audio files but I don’t see any in the version I download from gitlab. Are you using any audio/sound in the task on your end? If you are, can you try to disable them and see if that makes a difference?

Hi suelynnmah, I solved this problem. This problem is caused by network problems, and the URL can not be parsed correctly, and cannot be directly accessed in China. So I should access the online experiment by using VPN.

1 Like

I’m glad to hear you solved it! :smiley:

Do I understand correctly that the page loaded after you used this URL? So basically the did not work?

Yes, I think it was due to the CDN parsing problem after I open the experiment URL. When I opened the experiment URL, the experiment needed download from Pavlovia server, but the downloading URL like can not be accessed in China. I can directly open the experiment 3 or 4 days ago, but the network problem started about the day before yesterday. So I think the problem caused by the CDN parsing of Pavlovia server. I just found a relative post:
Expired Certificate Chain when making requests to - General - Cloudflare Community