Initialising the Experiment

URL of experiment:

Description of the problem:
Hi everyone,
I know this is a problem that’s reported quite a lot but I have absolutely no idea what the issue is. I’ve tried opening the developer tools when in the java script window but I have no idea what the errors actually are as I’m very new to coding.
The experiment was working fine until a added the last four routines. The experiment also works perfectly fine in PsychoPy so I don’t know why putting it online is causing it not to load.
If anyone knows how to fix this issue please let me know.

Serial_Recall_and_questionnaire.psyexp (85.4 KB)

What are the errors you get in the console?

Thanks for the reply, I think I might have solved this issue and run into another one.

When I opened developers tools it was an uncaught syntax error in the ‘form’ component (‘dark’,), instead of [‘dark’,], which PsychoPy hadn’t converted so I changed this. It then loaded all the resources but removed all the “var”. I updated the experiment with the form component disabled and it ran fine. When I enabled it again this is when all the lines starting with “var” disappeared and so I had to enter them all into the java script manually. This fixed the initialising problem. I’m now struggling with making the form component work properly as scrolling to more questions doesn’t work, the labels on my ratings scale don’t show and it doesn’t fit properly inside the box.

Yeah, the form component has some rough edges still. Maybe consider using a embedded page with a form instead?

Thank you for the suggestion, I may well give that a go after Christmas. If not, I think a simple Text display and a scale within a loop would work. I am still very new to coding.

1 Like