Experiment stuck on 'initialising the experiment' only for some participants

Description of the problem: My experiment for the most part seems to work fine - I ran it with a participant this afternoon and can run it myself on my own computer perfectly. However, occasionally I get a participant who gets stuck on ‘initialising the experiment’ after they click ‘Ok’.

I have got them to try closing and re-opening the Pavlovia link, restarting their browser (Google Chrome) and restarting their actual computer- none of which helped. I am assuming it must be something relating to this particular participant’s computer as it works fine for me, but does anyone have any idea what could cause this issue?

I saw this recent post: Online experiment stuck at ‘Initialising the experiment…’ - #9 by wilson
But myself and my participants are completing the experiment in the UK so I’m not sure this could be causing the issue? Any help or ideas much appreciated as this is causing me to lose valuable time and data!

If anyone would like to investigate further and see the experiment, I’m happy to provide access, just let me know as it’s not public.


Have you seen any pattern?

Location (e.g. China)?


Pilot participants (who may be seeing an earlier version)?

Hi @wakecarter thanks for the reply.

I haven’t identified a pattern yet, and worse still, I had the same error with another participant this morning on a different experiment, so the error isn’t experiment, or participant-specific. Today my participant tried running the experiment on an entirely different computer and had the same error. I have had this error happen now in Edge, Firefox and Chrome, so it isn’t browser specific either.

I took some screenshots of the Developer Tools console on the participant’s computer, which are here:

Also, when they pressed the ESC key to exit full screen, an error flashed up for a second but then disappeared, and it was too fast for me to take a photo or note down exactly what it said. It was something about looseContext if that means anything?

The experiment still works perfectly when I run the link on my own computer so I have no idea why this is happening, but I have another two participants this afternoon so really need to resolve this ASAP.

Please could you try to run it and let me know if you experience the same issue? The link is here and I have attached a credit for you to test it:

I associate “Lose context” with a memory error, which would explain why it is intermittent. How many resources are being downloaded? What is their total file size? Could you do anything to reduce that?

Hi @milsandhills,
I suggest you can try this solution:
"cdn jsdelivr net" has been blocked in China, is there any possible change the source of css?.
I think the cdn problem may not be unique to China.

And this one may be also helpful

@wakecarter there are quite a lot of resources - around 2-300 (it varies depending on the experiment as I am running two simultaneously). So that may explain the issue. I don’t think I can use the resource manager as I am using v2021.1.4, and I think this isn’t available for this version?

@wilson thanks for the suggestions - I will have a look into this cdn problem. I am hesitant to start messing around with the index file as my experiments have been working fine for months (after it taking ages to get to this point), so I may need to create some separate Pavlovia experiments to ensure I don’t compromise my existing experiments - I will report back.

Thanks both!

If you are using an older version you could upgrade, or use code components to load resources on the fly.

Have a look at my crib sheet for how to do this.

1 Like