psychopy.org | Reference | Downloads | Github

Online experiment no longer syncing: "None points to a remote that doesn't exist"

URL of experiment: https://pavlovia.org/cogdevlab_osu/mcneill_semprime_word

Description of the problem: I have been putting together an experiment over the past couple days. As of yesterday, I was able to sync the experiment normally and pilot it online without issues. This morning, I made a few minor changes in Builder, none of which involved the experiment’s code components (e.g., added a text component, changed the wording of an instruction, etc). However, when I tried to sync, I got a window with an error saying “None points to a remote that doesn’t exist (deleted?)”.
The Experiment name, name of the experiment on Pavlovia, and .psyexp file name are all the same, I haven’t changed the names/locations of any files or folders, and I am using the same computer. The version of the experiment online that was synced yesterday is still there and still runs fine.

I have been running into the same problem today, having created 2-3 new projects in the time span of a few hours because of the error “None points to a remote that doesn’t exist (deleted?)” that appears to occur sporadically. In my last change, I had made a few changes to text component positions and had erased existing data in preparation of testing real participants.

I normally wouldn’t find this an issue, but because my experiment is very image-heavy, I’m required to wait approximately 20-30 minutes every time this error occurs before I am able to test whether it works.

Any workarounds for the problem or explanations for this error would be helpful!

Did you solve this? I’m having the same issue now.

Same problem here, let me know if you find a solution please !

@Marina_Chrisi, @Andreetta can you please post links to your tasks for debugging? It usually means there is a “None” somewhere in the Python code, and it has been written over to the JavaScript - None is not a type in JavaScript so will throw an error.

I am also having troubles to initialize the experiment. it runs smoothly on my computer however when I try to pilot it online it asks me for participants informations and then the screen remains black and the experiment does not start.

Thanks @Marina_Chrisi, there are several Python and Builder experiments in your repository, which one are you trying to run?

I have the same problem. I can upload an experiment, but when I change something in the experiment and then try to sync it with Pavlovia it gives the error message “none points to a remote that doesn’t exist”… any solutions?

The English A

Hi, has anyone found any way to address the sync issue, where builder does not recognize that the project already exists on Pavlovia?

Is the “None” in that message just from the way syncProject is initialized?
syncProject(parent, project=None, closeFrameWhenDone=False)

I tried the only available option: (Re)create a project, and then named the “new” project the same as the existing Pavlovia one. Eventually the updates appear as a new commit, but it seems like this could create other problems so still looking for a solution. Thanks!

I had some success fixing this issue by changing the remote URL. When I checked it with:

git remote -v

I found it was not pointing to the correct place. After correcting it with

git remote set-url origin [repository URL]

and restarting PsychoPy, I found that builder once again recognized the project existed on Pavlovia, and no longer had the “None points to a remote that doesn’t exist” error.

2 Likes

Where do you type this? Does it involve downloading git? Where would I get the correct thing to download? I tried downloading something called Git Bash for a previous attempt and the git commands I was trying to run were unknown to it.

Thanks in advance,

Wakefield

You may need to install Git itself. You should be able to find the latest version here: https://git-scm.com/downloads

The commands above, I just typed into the windows command line, so nothing else should be required, though you may have to change your directory to whatever folder your project is in. You should be able to do this with

cd [filepath to your project here]

I just ran into the same problem. I followed the advice Reed gave in checking that your repository is in the right folder.

What worked for me was going to the Pavlovia.org drop down menu (to the left of Help and to the right of Demos) in the desktop Psychopy program, and clicking New or Sync from there. When I pressed the ‘Run the study online’ (the one with the globe and the green running man), it gave me the ‘none’ error, but when I ran through the Pavlovia.org drop down it worked fine.

I hope that helps!

Hello! I am having the same issue. I have to recreate the project every time I do a small change in Psychopy3. I’ve tried both syncing using the Pavlovia.org menu @PSYresearcher and by changing the remote URL as @Reed-Decker but it does not work for me. Did anyone figure out how to fix this?

I’ve been stuck with the same problem as you. I need to recreate the project if I leave it open for a while, but if I quickly make the changes after recreating then it allows me to sync for a short period. Not sure why this is the case, it is a lot more trouble to be doing it this way but I am just glad that I am able to upload any changes.

I started facing the same issue, what fixed it for me was to delete the html folder completely (or make sure you are creating a new unique folder for the experiment with no other experiments in that folder).