Cannot sync experiments to Pavlovia

I have set up some experiments on Pavlovia, and initially, I had no issues uploading the experiment and syncing, but recently, I get an error message that prevents me from resyncing any changes I make locally, attached below.

I have had to delete the experiment from Pavlovia and then reupload for now. I have a few experiments under one directory, but each has its own folder containing the Psychexp file and all required resources. I think the error arose after once I designed multiple experiments, so I think that may have something to do with the issue. Have anyone encountered a similar issue or have any ideas?

The key part of the error message is normally at the bottom – so you’d need to scroll down.

One common reason for an error when syncing is a coder related bug. If that’s the issue, close the coder view and try again.

1 Like

Hi Mr. Carter,

Thank you for your reply. I tried syncing again, with a different project, and I still get an error message. I scrolled down, and the screenshot is attached below.

It says that it could not find a project with some different GitLab ID, althougth the ID for my project is #271980. I am not sure why it is searching for some incorrect ID.

Some of these “could not find project” errors are fixed in the very latest version (2022.2.5), but if the ID is actually different from your project I would guess that the file you’re working with is linked to the wrong project, maybe one that’s been deleted. Was this experiment previously linked to a different project?