psychopy.org | Reference | Downloads | Github

Problems syncing existing experiment - "None points to a remote that doesn't exist"

I have a fully working experiment on Pavlovia.
I needed to make some changes in the builder file but when I try to sync it (previously worked just fine) it says “None points to a remote that doesn’t exist”.
I don’t really want to create a new project as I’ve started data collection already!

Does anyone know what causes this problem or how I can fix it? Thanks!

You should be able to export to html locally and then upload the changed files to gitlab manually.

Hey, thanks so much. Sorry but I’m totally new to this. How do I “export to html locally”? I did have a look under “code” where my experiment files are but I can’t see an obvious way of uploading a new file?
Thanks again!

When I look at the files for that project, I notice when I click on the psychopy experiment file that there is an option to “replace” but I am reluctant to click it in case this is not the right thing to do and I mess up my experiment!

File - html to export locally.

I think you want to replace the file with a new copy but I’m also new to this.

Okay, so I’ve replaced the experiment file with the updated one. This was easy enough. I check the files under “code” and yes the experiment file is now the new (replaced) one. Yet when I run the experiment online it is somehow using the old file!!! I don’t even know how or where it accesses this old file from as I have now replaced it??? Hmmm.

I also tried deleting my browser history etc as sometimes that causes problems. But that didn’t help. Am I now forced to create a new project because I can’t sync or replace my experiment file…? There must be an easier solution…
Thanks again:-)

If Pavlovia refuses to run the latest upload of your experiment, disable the cache via Network conditions in the browser console.

However, this shouldn’t affect your participants.

Hey, I think it does affect my participants because when I send the link for the experiment to another computer the same (old) version of my experiment comes up…
Disabling the cache doesn’t work either.

Somewhere it must have an old version of my experiment stored which it is running, but I can’t work out where!

Thanks for your suggestions, I really appreciate you taking the time to answer my question. Unfortunately neither of those options worked and so I just created a new project.

I do now again have the same problem (if I make changes to the script it can’t sync and plays the old version), so I guess every time I change the experiment I’ll have to create a new project!

Still I’m glad it is working!