psychopy.org | Reference | Downloads | Github

One specific experiment opens then closes immediately

OS: Win8.1
PsychoPy version: 2020.2.5

Problem: I created an experiment in builder displaying pairs of random dot stimuli moving in different directions. I was able to create an experiment that worked fine on my machine, then sent it to others to test it out. Initially it seemed to be working fine, but then recently both of my testers reported that when they tried to run the experiment, it would briefly open up a blank grey screen, then close itself.

  • There were no error messages.
  • Both were running the experiment on Macs. However, they were both able to successfully run other experiments that I had created without any issue. The main difference is that this experiment uses the Dots component.
  • I am still able to run my original experiment without issue.

I tried recreating the experiment exactly on my own computer using the same specs and components. Strangely, this actually replicated the error - when I try to open this copy of the experiment, it opens up a grey screen then closes itself. The only clue is that when I tried to export the copy to the coder to try and compare the code for the two versions, it failed. Instead, a dialog box says “Failed to open [file pathway]. Not a file.” Other than this, there are no error messages when I try manipulating the copy. The original version of the experiment is able to successfully be exported to the coder.

I have no idea what could be causing this, but if anyone has any ideas, I would greatly appreciate it!

Could you share the .psyexp file? It would help to see what the experiment is trying to do

MotionDirDiscrim1.0.psyexp (47.3 KB)
MotionDirDiscrim1.1.psyexp (47.5 KB)

Version 1.0 is the original version that I created that seems to only work on my machine. Version 1.1 is the exact copy that I made that doesn’t seem to work on my machine. The xlsx file is the conditions file needed to run the experiment.

MotionDirDiscrimExp.xlsx (9.5 KB)

This is the conditions file for running the experiment. Apologies for multiple posts - I’m unable to upload more than 2 files at a time.