Psychopy will not open on multiple computers


I have recently finished 2 experiments using the builder and I have been trying for several days now to put the programs on my participant testing computers. Suddenly, when I try to open my .psyexp files, the black window opens, and sometimes I see the white Psychopy intro box with the logo and university name, and then everything just exits. It never gets to the point of opening the .psyexp or the runner or anything else. I have also been trying to just open Psychopy to see if it is my experiment, or the entire software program. And now Psychopy will not open at all, and the same thing happens (black window, intro box, closes).

I copied my experiment to my flashdrive (while it was still working perfectly fine) and moved it to two of my testing machines, and am having the exact same issue now on those systems. Both when trying to open from the .psyexp I created, and also from the Psychopy install folder…

I have looked at other posts and some have mentioned that on Windows computers (all of the systems I’m using are Windows), the issue is it will hide the program, and you can right click the taskbar and select cascade windows to see if it is open. I tried this and it was not the issue. I also have uninstalled and reinstalled psychopy on my laptop (I’ve been using version 2022.1.2 so I reinstalled that same version in case my programs would not work with newer version) and it opened properly once. And then never again.

I’m becoming very worried as now I am behind on my deadlines and my advisor is unhappy with me. So any ideas would be greatly appreciated!

Two questions:

  • Can you run the .py file on the testing laptops?
  • Did the installations only stop working after you opened your experiment for the first time or did they stop working before? Do they work again after deinstalling, deleting all traces of PsychoPy and reinstalling?

Edit: Another question for clarification: Does the experiment work on the machine you programmed it with?

The computer I created it on is where the issue started. I could no longer open the .psyexp to edit it, or run the .py to test it.
When I moved it to the other two computers, the .py worked but I could not open psychopy.

I went ahead and downloaded the newest version of psychopy on the two testing computers, and now I am able to open the .psyexp and everything else. I will be trying the same on my own laptop.
The other postings I had seen were also about version 2022.1.2. So I think it was probably just an issue with that version. Or at least I’m hoping so!