psychopy.org | Reference | Downloads | Github

nReps not Syncing between Off- and On-line Experiments

URL of experiment: https://pavlovia.org/BevPJ/honeycombonline

Description of the problem: I created a simple 2AFC experiment in Builder that included just one rep for each of the 24 trials. I show an image and the participant presses one of two keys to respond.

Now that I’m ready to run my experiment, I changed the nReps in the Trial component to 10. When I run the experiment in Builder, I get the expected 240 trials. However, after syncing (successfully, apparently) to Pavlovia, I still only get the 24 trials (one rep per stimulus).

I’ve also tried manually pushing and pulling and committing via Git, but to be honest I’m just copying solutions I found online without much insight into the process!

Any help would be greatly appreciated. Thanks!

NB: I have now tried deleting everything and starting over again! My new experiment URL is https://gitlab.pavlovia.org/BevPJ/honeycomb-online-experiment-2
or https://pavlovia.org/BevPJ/honeycomb-online-experiment-2

The sync appears to work. When I try to run the experiment online, I get this error:

403 Forbidden

nginx

The experiment runs on the Builder…

Additionally, EVERY time I close PsychoPy down, the experiments stop syncing and I have to recreate the experiment (e.g. when I press the ‘run’ button, I get the error message that says “none points to a remote that doesn’t exist (deleted?)”. When I recreate the project, it’s fine - until I close PsychoPy down, and then the fun begins anew.

If your experiment won’t sync to Gitlab, the safest way to create a new experiment on Gitlab is to duplicate your local experiment folder and then delete the hidden folder called .git from inside it. Then open the duplicate study in PsychoPy and sync as before so that it will ask to create a new project. [jon]

Are you deleting the .git hidden folder?

Best wishes,

Wakefield

Thank you for your reply - I found the hidden folder on y local machine and deleted it. I exported the HTML and then recreated the experiment by clicking ‘Run’ on the builder. I changed the status to Running on Pavlovia (new URL: https://run.pavlovia.org/BevPJ/honeycomb-copy-1/html). I can see that the files have been created. However, when I try to run the experiment I still get the 403 error…

Try changing it to inactive then active again

Thanks again fo your reply - I’ve tried this and unfortunately it still gives the 403 error. It does sync, though.

I just tried exporting the HTML manually, changing the status from ‘running’ to ‘inactive’ and back again to ‘running’, then synced the experiment (successfully), and then tried to run it again. 403 error. It does run from builder, still.

Would appreciate any other suggestions - and thank you for your help so far!