psychopy.org | Reference | Downloads | Github

Problem with Experiment in Pavlovia

#1

URL of experiment: https://gitlab.pavlovia.org/himynameisclara/ss_training_day1
Project ID: 4260

Description of the problem: I have created an experiment in PsychoPy which is running well on my machine. I uploaded it to Pavlovia from PsychoPy however, when I press Launch on Pavlovia I get a 403 Forbidden Nginx error.

Has anyone encountered the issue before? And how did you resolve it please?

Thanks in advance!

0 Likes

#2

It looks like your experiment didn’t sync the files properly. When you press sync in PsychoPy what happens?

0 Likes

#3

It gives me the following:

Synchronising…
Pulling changes from remote…
Already up to date.
done
Pushing changes from remote…
done
Successful sync at: 15:18:52, took 1.138s

0 Likes

#4

I don’t understand. That sounds successful, but only one file is getting pushed to the server. I’m at a loss as to why this is occurring I’m afraid.

0 Likes

#5

When you synced the files, did you write something in the ‘Summary of changes’ dialogue box, or did you just press OK, leaving the dialogue box blank?

0 Likes

#6

I left the dialogue box blank. Should I write something?

0 Likes

#7

I will try and upload it from a different machine and see if I have any luck with that! Thanks :slight_smile:

0 Likes

#8

Yes, as @unagi_pie suggests, you will need to write a commit message otherwise the sync will fail. You should see an error in your console (if Coder is open), such as

  File "C:\Users\lpzdb\psychopy\psychopy\app\builder\builder.py", line 2379, in onPavloviaSync
    pavlovia_ui.syncProject(parent=self, project=self.project)
  File "C:\Users\lpzdb\psychopy\psychopy\app\pavlovia_ui\project.py", line 477, in syncProject
    outcome = showCommitDialog(parent, project)
  File "C:\Users\lpzdb\psychopy\psychopy\app\pavlovia_ui\functions.py", line 150, in showCommitDialog
    project.commit(commitMsg)
  File "C:\Users\lpzdb\psychopy\psychopy\projects\pavlovia.py", line 950, in commit
    self.repo.git.commit('-m', message)
  File "C:\Program Files (x86)\Python36\lib\site-packages\git\cmd.py", line 548, in <lambda>
    return lambda *args, **kwargs: self._call_process(name, *args, **kwargs)
  File "C:\Program Files (x86)\Python36\lib\site-packages\git\cmd.py", line 1014, in _call_process
    return self.execute(call, **exec_kwargs)
  File "C:\Program Files (x86)\Python36\lib\site-packages\git\cmd.py", line 825, in execute
    raise GitCommandError(command, status, stderr_value, stdout_value)
git.exc.GitCommandError: Cmd('git') failed due to: exit code(1)
  cmdline: git commit -m 
  stderr: 'Aborting commit due to empty commit message.'```
0 Likes

#9

Thanks for the response. Unfortunately I tried uploading again from a different device, and also wrote a commit message but no success :frowning:

0 Likes

#10

Would you mind sharing your experiment and associated files so we can see if anything is happening with files?

0 Likes

#11

That would be of great help! Should I send them to you via email? There’s quite a few image and sound files.

0 Likes

#12

Great, you can just send a zip file either on this post, or by direct message on here.

0 Likes

#13

himynameisclara, Have you solved this issue, if yes pls share the solution. I am experiencing the same problem

0 Likes

#14

Hi @Lukamark, what is your actual issue? Can you post a link to your online study so we can see the error?

0 Likes

#15

The reason was trivial. I haven’t exported HTML before uploading study to Pavloivia. Shame on me!

0 Likes

#16

Hey, I am facing the same 403 error when I activate and launch. I tried everything like uploading again after deleting git files.

I sync from psychopy, go to pavlovia (activate and launch)

Am I missing some important step?

0 Likes

#17

Hi, I have been encountering the same issue. Did anyone find out an solution for it?
Might this be due to the fact that I am trying to upload the .py code file and not the .psyexp file?

Thank you in advance.

0 Likes

#18

Hi @rob-linguistics13, you need to have exported the HTML and JavaScript from Builder in order to have a valid PsychoJS task that will run on Pavlovia. Take a look at these guidelines for running online studies.

0 Likes

#19

Thanks! I had already read the web page you posted, but I did not understand that only experiment from the Builder may be uploaded on pavlovia.org. I’ll try and see if this solves the issue.

0 Likes

#20

Any files can be uploaded and from command line as well, but if you want to run a task from Pavlovia, you need the html and JavaScript that Builder exports

0 Likes