Initalising experiment doesn't load

URL of experiment:Pavlovia

Description of the problem:

Hi there,

I’ve created an experiment in builder and have had confirmation that it has synced to a project on my dashboard. The experiment status is set to ‘piloting’ but when I go to run the experiment it holds on the ‘initalising’ screen.

So far I’ve:

  • ensured that the name of the experiment and settings are the same
  • uploaded all the relevant files to GitLab
  • checked the paths from my local file structure to the experiment.
  • Reviewed this forum and been through the user guides for how to upload to pavlovia.
  • checked each of my code snippers to ensure they’re converting into JS.

Any ideas on what might be causing the issue is greatly apprecaited!

What error are you getting in the developer console?

I’m getting this:

Failed to load resource: the server responded with a status of 404 ()

Failed to load resource: the server responded with a status of 404 ()

When I look at the local file the files listed (data folder, psychopy experiment, conditions excel sheets) etc mirror the files in my GitLab. However, Reward_Learning_Task.js is not a file I have or can see has been created automatically so I’m thinking this may be where the issue is, but I can’t be totally sure.

Thank you!

Change the name of the experiment in Experiment Settings to match the file name.

Thank you again for the help. I’ve made sure that the file name and Experiment name match. I’ve just tried again to synch and am getting the error ‘The file doesn’t belong to any existing project’. When I set up a new experiment it looks like all the relevant files are there but I get the same error even when it’s in pilot mode. When I create a new experiment I get the confirmation that the synch has been sucessful.

What I do notice is that on the experiment page it says ‘Software platform - unknown’. I’m assuming this is because it can’t work out the software platform it is due to an issue with the sync but I thought i’d flag.

Is there a js file in the Gitlab repository? “Software platform - unknown” suggests that a file hasn’t been created or it doesn’t match the one in index.html

1 Like

There was but this prompted a thought for me to check the HTML code of the page which was trying to load and it was trying to pull another random file name there. Have made them all the same and it has worked so thank you for the help!

If there was a random name in index.html then it is probably the name of the experiment in Experiment Settings in Builder. If you’ve changed the file directly you may need to rechange it next time you sync

1 Like