psychopy.org | Reference | Downloads | Github

Pavlovia not updating

URL of experiment: Pavlovia

Description of the problem:

I have made several changes in the builder and synced them successfully to Pavlovia. The dialogue box says that the syncs have been successful, the sync icon turns green, and GitLab is updating just fine. It’s just the actual experiment page on Pavlovia that hasn’t registered any of the updates I’ve made in the last 2 days (it says it was last updated on 9-18-21).

Some other users have recommended clearing cache and browser history and then reloading the page, but that hasn’t worked either. I’m not sure what to do at this point aside from deleting the experiment and reuploading it, but I’d rather not do that unless I have to. Does anyone have any advice?

Thanks!

Try incognito mode

Or Ctrl Shift R

I tried both several times and neither worked, unfortunately.

Do you have more than one index.html in your repository? Eg root and html folder?

I just have the one. I changed the experiment status to inactive and then back to piloting, and that changed the last updated date. However, now I’m just getting a blank white screen and no error messages when I reach the point in my experiment that I was trying to update.