Experiment stuck synchronizing in initial sync to pavlovia from builder

Description of the problem: I have a new task that I’ve created largely from copy/pasting routines from previous tasks (this is simply to put multiple tasks w/n one for online participants). I tried to sync to pavlovia and although it was successful, it had some errors in the output of the PsychoJS script (height selection for some image/video variables was being generated as unit=‘height’ rather than unit: ‘height’). This prevented the html folder from being created during the sync. I deleted the failed-to-sync-properly experiment from pavlovia. I updated the units (to not be height) and I deleted the hidden git folders from previous failed sync in my local folder. I also manually exported the html folder and verified that all resources and psychoJS scripts look OK (previously vars were not being created). Everything looked good, so I then tried syncing to pavlovia and it says that this project doesn’t exist and asks if I want to create a new project (I ran it this way as a check to make sure pavlovia thought it was new). It then began synchronizing, but it has been stuck on this ‘Synchronizing to pavlovia’ window prompt for the past few hours. On the output it states, ‘Generating PsychoJS script … Generating PsychoPy script…’ and nothing else. I’ve looked online and the task is listed (although it’s still trying to sync), it just says that the repository is empty. I’ve run the task locally without any issues and with no errors. I did reset the export HTML to on ‘sync.’ Could that be an issue, since I already generated the HTML folder locally? Should I delete it? If not, I’m wondering if there are any suggestions for how I can get it to sync to pavlovia. Thanks!

I checked again about 10 hours later and it was still stuck on the ‘Synchronizing to Pavlovia’ window prompt. I deleted the empty repository from pavlovia, removed the hidden git folders locally, and I removed the html folder that I had produced locally. Removing the html folder allowed the sync to Pavlovia to go through; however, it did not produce an html or resource folder during it’s ‘successful’ sync. So, it is still not functional online. Is there a way that I can upload the html folder I created locally w/ all of its embedded resources (400+ files) in an easy way to the pavlovia project? It looks like in most cases you can only upload one file at a time.

I tried to re-sync the experiment to pavlovia after re exporting the local HTML folder manually, but I had the same issue as before where it stalled in the ‘synchronizing to pavlovia’ window prompt for an hour. I stopped the process and I’m now trying to load each of the files manually online.

I think that uploading manually isn’t likely to get you a working experiment. I suspect that there is a syntax error or similar which is preventing the sync. For example, I recently spent an hour unable to sync an experiment someone sent me – and eventually discovered that the issue was that one of their column names was “list”.

@wakecarter Thanks for the reply! Yes, that is my fear, that it won’t work after uploading everything manually… Do you have suggestions for identifying the potential error in syntax? Locally, I do not show any errors. On my initial creation of the PsychoJS script (manual export of HTML) it had an error with using the unit ‘height.’ I was able to change this and no other errors have appeared and it runs fine locally.
I’ve run smaller versions of this program online in pavlovia w/o issues and without issues with the sync (the excel files and properties have not changed from those programs). The only thing I changed was updating one of the tasks end slide to a transition slide. Those programs are within their own folders as is this task (with no other psychopy programs w/n the folder).

What is a transition slide?

Can you disable potentially buggy components in order to get the initial sync done?

@wakecarter Just a slide with text telling participant that they can take a break before the next task and once they are ready they can press the space bar. It’s just a routine with text and keyboard input. And is there a way to ‘disable’ a component - or do you mean removing an item (e.g., code component) from a routine or removing a routine?

Each component (apart from code components pre 2021) can be disabled Under the Testing Tab, or a routine can be deleted from the flow.

@wakecarter thanks. i’ve tried removing a couple of items and it’s trying to sync now. still same issue that it’s stuck - but I’ve also been alerted that our internet is down… so that may be the current issue. i’ll update if I make any progress.

@wakecarter I kept trying to remove routines one by one, but encountered same issue. I ended up removing everything aside from 5 text slides with either a keyboard response or slider rating. it still won’t make an html or resources folder when trying to sync to pavlovia and if i make one manually it fails to sync (just ends up getting stuck on the synchronizing window prompt). I’ve tried moving the experiment over to a new directory 3x so far w/o luck too. Although each time after i’ve tried to sync i removed it from pavlovia (settings-> general-> remove) and removed the hidden git folders/ normal html/data folders from the experiment folder, I’m going to start from scratch again in another folder.

I don’t think I can help any further remotely on this. However, if rebuilding doesn’t work or you think will take you too long, you might be interested in this post.

Could you give this another go in the latest version? We’ve put in a lot of bug fixes since you encountered this problem and would be helpful to see if your issue was caused by one of the bugs we fixed