psychopy.org | Reference | Downloads | Github

Error when trying to download experiment data form database

I am trying to download data from a completed run of my experiment from the database via my dashboard on pavlovia (https://pavlovia.org/lr/megabit_n_back).

All I get is the following error

Is there anything I need to change in the experiment settings?

Hello @lrier,

Some of the special characters in your experiment results were not dealt with adequately, which created that particular error.
I am now dealing with them in a much more robust manner, and your results are correctly collated into a .csv file.
Many apologies for the mishap!
Best wishes,

Alain

1 Like

Hi, I am getting the same message - how did you fix it ?

Hello @cami94,

You just encountered a small regression in the code. I’ve just fixed it.
You’re good to go :slight_smile:

Alain

thank you!!

I encountered the same problem here @apitiot
Experiment link:
https://pavlovia.org/run/Wendyli159/semantic-category-judgment-task/html/

Error message
when downloading the experiment results:

{“origin”:“http://pavlovia.org/api/v2/experiments/Wendyli159/semantic-category-judgment-task/results",“context”:"when getting the results of an experiment”,“pathWithNamespace”:“Wendyli159/semantic-category-judgment-task”,“experiment”:{“gitlabId”:21619,“avatarUrl”:"",“creationDate”:“2020-03-31 01:46:29.808”,“creatorId”:4080,“description”:"",“gitlabUrl”:“https://gitlab.pavlovia.org/Wendyli159/semantic-category-judgment-task.git",“name”:"semantic category judgment task”,“nbForks”:0,“nbStars”:0,“pathWithNamespace”:“Wendyli159/semantic-category-judgment-task”,“pavloviaScore”:0,“platform”:“PSYCHOJS”,“recruitment”:{“policy”:{“type”:“URL”,“url”:“https://run.pavlovia.org/Wendyli159/semantic-category-judgment-task/html",“singleRun”:false}},“runMode”:“CREDIT”,“saveFormat”:“CSV”,“status”:“INACTIVE”,“status2”:“RUNNING”,“updateDate”:"2020-04-02 16:11:49”,“userIds”:[4080],“visibility”:“private”,“lastActivationDate”:“2020-04-01 02:25:01”,“nbSessions”:1,“pavloviaUrl”:“https://run.pavlovia.org/Wendyli159/semantic-category-judgment-task/html",“htmlPath”:"/html/",“version”:“2020.1”},“isOwnedByUser”:true,“error”:"error when preparing the result archive, exitStatus: 3072”,“errorCode”:null,“httpStatusCode”:500}

If the error persists, contact Pavlovia’s administrator.

Is there a way to fix it?

Hello @Wendyli159,

The issue had to do with your not having any data to download. So the server complained, correctly, but pavlovia.org did not handle that complaint correctly. I will fix that this morning.
That being said, you now have two results, it appears. I have just tried to download them and it worked perfectly. Would you like to give it a try yourself?
Cheers,

Alain

1 Like

Sorry to bother you, but I am also having the same (or at least a similar) problem:

{“origin”:“http://pavlovia.org/api/v2/experiments/kobebest/mrep/results",“context”:"when getting the results of an experiment”,“pathWithNamespace”:“kobebest/mrep”,“experiment”:{“gitlabId”:21901,“avatarUrl”:"",“creationDate”:“2020-04-01 08:02:58.621”,“creatorId”:2598,“description”:"",“gitlabUrl”:“https://gitlab.pavlovia.org/kobebest/mrep.git",“name”:“MRep_Test”,“nbForks”:0,“nbStars”:0,“pathWithNamespace”:“kobebest/mrep”,“pavloviaScore”:0,“platform”:“PSYCHOJS”,“recruitment”:{“policy”:{“type”:“URL”,“url”:“https://run.pavlovia.org/kobebest/mrep/html”,“singleRun”:false}},“runMode”:“CREDIT”,“saveFormat”:“CSV”,“status”:“INACTIVE”,“status2”:“PILOTING”,“updateDate”:"2020-04-03 08:52:48”,“userIds”:[2598,4973],“visibility”:“public”,“lastActivationDate”:“2020-04-01 17:03:03”,“nbSessions”:1,“pavloviaUrl”:“https://run.pavlovia.org/kobebest/mrep/html",“htmlPath”:"/html/",“version”:“2020.1”,“keywords”:[“mental_representation”,“test”,“pilot”]},“isOwnedByUser”:true,“error”:"error when preparing the result archive, exitStatus: 3072”,“errorCode”:null,“httpStatusCode”:500}

I have just fixed the issue I mentioned above.

Incidentally, your experiment is currently in PILOTING mode and was either never in RUNNING mode or no session was run when it was in RUNNING mode. Consequently, no experiment results are stored on the server.
When you change the experiment status to RUNNING, you will be able to download your results using the [Download Results] button.
Cheers,

Alain

Thanks Alain! it works now.

However, only the results collected in the running model were downloaded. The pilot result does not. I don’t really need the pilot result, so I am not worried about that. Just let you know how it works now.

Thank you a lot for your quick reply!

Wendy

The PILOTING results are indeed not stored on the server: they are immediately downloaded at the end of your PILOTING session.

I am glad that all is well!
Happy experimenting :slight_smile:

Alain

Oh I see! Thank you!!!

Hi, Sorry to bother, I encountered the same problem today, here the link of my project:
https://pavlovia.org/xuanyufang/fangthesisgroup1
It shows me 15 data in the database, but I couldn’t download it.

Hello @Frank_Fang,

Your experiment is in piloting mode. Consequently, as explained above, results are not saved in the database. And so there is nothing for you to download.
For those results to be saved in the database, you would need to change your experiment to running mode, and assign credits to it.
You will find more information about the matter on our experiment documentation page: https://pavlovia.org/docs/experiments/piloting-running

Alain

Hi,

Also getting an error. The error says:

"Error when downloading the experiment results:

"\r\n504 Gateway Time-out\r\n\r\n

504 Gateway Time-out

\r\nnginx\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n"

If the error persists, contact Pavlovia’s administrator."

I’ve previously downloaded experiments from the task without any problems.

Edit: There is a lot of data (>400 participants) - perhaps this is contributing to the problem.

I have the same error code appearing. I have previously been able to download my data but have not done so since getting a large influx of participants.

Is it just the size of the data causing a problem?

Probably. That’s what the issue was for me. The PsychoPy team were able to assist and send me a different link to get the data.

@apitiot would you be able to lend me some assistance with getting my data? Thank you!

Hello @carah12,

The issue had indeed to do with an excessive amount of logs, and so your result file was huge.
I have just dealt with it. You should be able to download it now, from your dashboard.
Cheers,

Alain

1 Like