psychopy.org | Reference | Downloads | Github

Can't download results: 504 Gateway Error when trying to download experiment data from Pavlovia

Hi,

I receive an error when trying to download my results from Pavlovia. The error says:

"Error when downloading the experiment results:

"\r\n504 Gateway Time-out\r\n\r\n

504 Gateway Time-out

\r\nnginx\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n"

If the error persists, contact Pavlovia’s administrator."

I’ve previously downloaded experiments from the task without any problems.

There is a lot of data (>400 participants) - perhaps this is contributing to the problem.

Any help would be much appreciated! My thesis deadline is fast approaching and it’s a bit stressful not being able to access the data!

Thanks in advance!

Ps: I had previously posted about this in an old thread (Error when trying to download experiment data form database), but since most problems in that thread seemed to relate to being in pilot mode or not having results to download, I thought I’d re-post in a new thread.

Hi @jon,

Do you know what might be happening here? If not, do you know who Pavlovia’s administrator is?

Thanks,
Josh

The fact that it reports a timeout does suggest that the file was too big and your internet connection got bored waiting. Is this using the database or csv files for data storage on the project? If the csv files then you could use sync from within PsychoPy (which will use git and should fetch everything). If you’re using database then you do need to use the download button on pavlovia that I assume you’re using so far

1 Like

I’m using the database, and yes using the download button on Pavlovia.

I ran speed tests on my internet before trying to download and it seemed ok. I also tried over a friends wifi, again without luck.

Do you think that it is just a matter of finding fast enough internet? Ie. should I try to get access to faster internet speeds and try downloading again?

Or is there any other workaround that is less sensitive to internet speed?

OK, I can see the project having the problem. I’ll look into it and we’ll work out how to get the data to you. It does run for a really long time before failing so I’m not sure what’s going on.

Thanks a lot @jon

Let me know if you need anything from me.