psychopy.org | Reference | Downloads | Github

Credit not released when the participant opens the URL and presses 'cancel'

If a participant enters the experiment’s URL but then presses ‘cancel’ (prior to even filling out the participant details), an empty result file is created and a credit is reserved, even though the participant did not even start the experiment. Why does this happen? how can the reserved credit be released?

Hello,

Same problem. All of my credits have been used up simply by someone clicking the link. The Pavlovia website clearly states:

Credits allow participants to run experiments, with 1 credit consumed each time 1 participant completes an experiment.

This doesn’t seem to be the case. Please advise.

Dear @Tal and @unagi_pie,

We have indeed experienced an issue with the release of credits, owing to a mismatch between the configurations of the development and the production servers. The issue has now been resolved.
Many apologies for the mishap! I am happy to let you know that your credits have all been released, without any of them being consumed.

I can confirm that credits are only consumed when participants complete experiments, and indeed you could notice on your dashboard that the credits were reserved rather than consumed.

Alain

Great. Thanks for the quick response!

Hi @apitiot ,

I am having a similar problem. I just purchased credits for my upcoming experiment. Before beginning data collection, I wanted to try out one the links of my experiment, just to make sure the URLs were working after changing the status to ‘running’. As a consequence, one of my credit is now “reserved”. What does that mean exactly? How can I cancel the reservation and make that credit available again? Thanks!

Hello @rob-linguistics13,

I believe you are referring to experiment: ucisynlab/5v_mp
I have just tested it myself: a credit was correctly reserved when I opened the experiment url, and it was free’ed when I aborted the experiment.
Do you still have the tab with the experiment opened and running? If so, closing it should free the credit.
If somehow this does not work, I’ll free the credit for you, of course.

Alain

Yes, that’s it.

I opened the URL, made sure it worked and then closed the tab; but the credit still appears reserved on my dashboard. I have also tried to quit and re-open Safari, but that didn’t free the credit either.

Oh dear, might it be yet another issue with Safari-which-does-things-differently-from-anyone-else?

Could I ask you to repeat the process for me? I’ll watch it live as it happens.

So, open one of the URLs of the same experiment, test it a bit and then close the tab?

Yes, exactly.

Open the URL. Leave it open for 1mn. Then close the tab without completing the experiment.

Ok, done.

Thank you very much. I can confirm that the issue is a Safari-specific one. I’m on it!
In the mean time, I’ve freed your credits.
Incidentally, we have a mechanism in place to automatically free credits after a day in case participants leave the experiment running forever.

1 Like

Thanks! Did you try this out with Chrome and Firefox? If not, I can do it for you and let you know.

Thank you @rob-linguistics13, Chrome and Firefox on Mac work like a charm. Safari is the only one making trouble, but I might just have found a solution.

Ok, keep me updated. I was planning to run the experiment later tonight, but I could push it back to next week, if you can’t a speedy solution. Thanks!

Do you want to give it another try right now? Make sure to empty your browser cache first.

1 Like

Now it is fixed! Once I closed the tab of the experiment, refreshing the page of the experiment info on Pavlovia freed the reserved credit. Thank you for the speedy fix!

My pleasure! Good luck with your experiment, and do not hesitate to get back to us, should you experience any issue.

Thanks for resolving the issue @apitiot!