psychopy.org | Reference | Downloads | Github

Blank screen appearing on pavlovia and images are in a different position from psychopy

URL of the experiment:

Issue at the end of screen 5:

https://run.pavlovia.org/arkadiym/od_r_1/html

Same issue at the end of the experiment:

https://run.pavlovia.org/arkadiym/od_e/html

Description of the problem: A blank screen appears after a text screen and images appear at a different position than on Psychopy. I am concerned about this, particularly for the second experiment because participants are not able to get to the end, and thus, might not save their data.

This appears on Pavlovia in both cases but not in psychopy.

I tried deleting the experiment numerous times, and re-uploading it. I also made sure that the experiment names are identical, since that was listed as an issue before.

I would love if anyone has a solution for this
.

Same issue with this experiment- a simplified version. The experiment does not advance past the last loop, and presents a blank screen instead of concluding text (next trial). Pressing a spacebar ends the experiment:

https://run.pavlovia.org/arkadiym/od_e_1_standard/html

What units are you using? That is, in your experiment settings, are you using unit type norm, pix, height? I suspect that’s probably the repositioning issue.

To have a look at the blank screen it’ll be easiest if you can link the repository (go to view code and link that page. Make sure it’s public by going to settings->general->permissions).

Thank you for looking into this- I just made the code public.

For pictures- I am leaving the size field blank and am selecting “from exp settings” from the menu.

For polygons- I am using pixels (pix).

For the fixation cross (plus sign, using text tool), I am entering the letter height.

If this is relevant, the last thing participants see before the end of the last loop (before, the blank screen appears), is the fixation cross.

The experiment settings say the units are set to “deg”, so anything using “from exp settings” as its units will not work or behave unpredictably online because deg units require screen dimensions and viewing distance, neither of which are currently available online. If you change the text objects and images to use pix, norm, or height, they should work better.

Thank you for these suggestions.

I changed everything from “deg” and make sure that there are no “Exp settings” but height or pix, instead.

I updated this experiment to run through only 1 loop for testing convenience (code is public): https://run.pavlovia.org/arkadiym/od_e_1standard_1loop/html

After the loop is over, the concluding text is still not showing. I am not sure if something is still off pertaining to units.

I did notice that every time I change the Psychopy settings from “deg” to “pix” it resets back. The automatic rest happens even if I click on a different tab, and come back to the original tab. Not sure if this is at all related, but if it is, wondering if there is a way to make a permanent change (screenshots attached of this).

That’s a straight-up bug. @jon or @Michael might want to have a look at that. Something in the preferences just isn’t sticking, but as long as none of the components are getting their units from experiment settings it shouldn’t matter.

The thing that’s not showing is the “conclusion” trial specifically? It might be something silly about the name of the text component. Try changing it from “text” to something else, e.g. “concludingtext” or something. Sometimes using names that are also objects confuses PsychoJS.

Makes sense- thank you!

Yes- the issue is with the last trial specifically- the conclusion trial.

I deleted and re-created that trial, and updated the last trial; the trials name now does not include the word “text” and the text stimulus is now titled, “conclusion1”; a few screenshots attached.

I am now getting an error when trying to run the experiment, which says: “text is not defined”.

New link: https://run.pavlovia.org/arkadiym/testing_short/html

Wondering if you might know why this is. The fact that that the error changed, does indicate that we are onto the root of the problem. Thank you for helping with this.

Screen Shot 2020-05-05 at 12.26.16 PM

As I often say, progress is failing differently.

In trial ID_3, in the “begin routine” part of the code component, the JS is trying to change the object text.text. In fact, that is the root cause of the end text being blank in the first place, because it was setting text.text to blank! Now that we’ve changed the name of the object, it just refers to nothing, hence the error. I think you just need to update that to “text11.text” to match the Python.

1 Like

Thank you for catching that!! That was the main issue here. Much appreciated!!

I would guess that your preferences are corrupted. See here for a trouble shooting guide:

https://www.psychopy.org/troubleshooting.html#cleaning-preferences-and-app-data

Hi @arkadiy, I just had a look and it seems like this bug where your specified “units” in the preferences isn’t being stored has already been fixed in the repo master branch and will be in the next release.

1 Like

Thank you for looking into this and for letting me know. By the way, congratulations on joining the Psychopy team!!

1 Like